FreePBX | Register | Issues | Wiki | Portal | Support

Cisco 8861 3ppc version firmware upgrade


(Andrew Byrd) #1

I know this is not freepbx related, but . . . . .

If anyone can steer me in the right direction I would sure appreciate the help

I am trying to manually upgrade the firmware in my Cisco 8861 3ppc version.

I downloaded a tftp program and made my computer a tftp server

I placed this in the rule field in the web gui under the provisioning tab

http://192.168.1.6/admin/upgrade?http://192.168.1.41/tftp://sip88xx.12-5-1SR3-74.loads

192.168.1.6 is the IP address of the 8861. 192.168.1.41 is my tftp server

I click submit changes and nothing happens

Any direction would be appreciated.


(Dave Burgess) #2

I don’t think either of those things are going to get you where you want to go.

  1. Add tftp to your phone server. The file /etc/xinetd.d/tftp should be there. Edit it so that “disable = no” instead of yes.

  2. Try “service restart xinetd”

  3. Go to your DHCP server and set IP-Address Option 66 (vice the URI one) to point to 192.168.1.4. Add the Option 66 entry to your DHCP profile for your phone. Restart DHCP.

  4. Restart the phone. It should pick up the Option 66 and TFTP the file from your /tftpboot directory.

Now, the tricky part is telling the phone to grab that image. I think you do it in one of the XML files for your phone, but I’m not sure about that, since I don’t use SIP for Cisco phones.


(Andrew Byrd) #3

Thank you for the reply. This is where I got the idea to do what I was doing. I see it accessing my tftp server, it just doesn’t ever update. I figure I have one missing paramater or character and that is what is holding me up

http://www.wavetelbusiness.co.uk/help-and-support/hardware-configuration/upgrading-cisco-8861-3pcc-firmware-using-tftp-server/


(Andrew Byrd) #4

I also tried this


(Dave Burgess) #5
  • Goto phone web interface
  • login as Admin/Advanced -> Goto Provisioning tab
  • enter below URL in UPGRADE RULE under Firmware section

tftp://192.168.1.2:69/sip88xx.12-5-1SR3-74.loads

where 192.168.1.2 is the IP address of your phone server. That way, you don’t have to mess around with opening your workstation to the inherent insecurity of TFTP


(Andrew Byrd) #6

Thanks Dave. I tried that and it keeps returning the message

Upgrade aborted with unknown error


(Andrew Byrd) #7

I have abandoned this phone line due to the complexity of setup, configuration and upgrades. Thanks Dave for trying to help.


(system) closed #8

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.