Cisco 79XX - Disable number auto-complete when blind transferring


When trying to perform a blind transfer on a Cisco 7942 phone, we try to dial the local extension, but if the extension is also a prefix for a previously dialed number, the phone will try to auto-fill in the rest of the number for convenience.

An example: We dial the number 800-123-1234 earlier in the day. Then later a call comes in, we answer, hit Blind Transfer button, and want to transfer the call to our extension 800. When we key in “800”, the number we previously dialed automatically appears and if we hit the “Dial” button on the phone, it will NOT go to the extension we keyed in, but instead uses the full, auto-completed number.

Is there a way on the Cisco phone to explicitly dial the local extension, or simply dial the extension and ignore the auto-complete?? Or maybe even a configuration setting to disable auto-complete all together?

Thanks for any insight you might be able to share. I’ve tried looking through the user manuals, guides, docs for the phone model, but don’t see any mention of auto-complete or how to force dialing only the entered numbers.

Looks like this document tells you how to find the setting for this.

Search: Auto-Complete

Once you do, you can export a configuration before and after. That will help you find the code involved.
If you are provisioning the phones you can simply change that code in the provisioner.

Thanks @Ajhad I found that user manual already, however I was hoping there was a key press to dial only the numbers entered and not auto-complete since the auto-complete is a nice feature most of the time.

Intuitively, it seems like I should be able to press the up/down arrow or another button to clear-out the auto-complete “suggestion” or to simply dial what I’ve entered so far. However, if I can’t find such a method, I’ll probably just have to disable auto-complete since otherwise, we have to restart (unplug) the phone to clear call history so auto-complete suggestions are cleared/empty.

Really appreciate the response!

I am not familiar with that model.

But, on other Cisco phones, there is an option to set the # sign as a send key.
This may or may not override the auto complete.

There are a few of other options as well but YMMV.

  • I would stay away from extension numbers that are common area codes. We actually don’t generally let anyone have the common ones for this reason.
  • You can try adjusting the Dial Plan.
  • You might try adjusting the Digit Timeout as well.

Your specific example of 800 is something we have run into in the past.
In those cases, the best and easiest solution has always been to not allow an extension to be a common area code. Most people dial the first 3 numbers of phone number then pause to dial the rest. This causes many incorrect dial attempts to extension 800 instead of the 800XXX-XXXX number.

If for some reason you need to have many extension ranges and you naturally reached 8XX. You may want to think about moving to a XXXX extension range to help with some of these issues.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.