Cisco 7975g SIP and asterisk

Hi All,

Has anyone gotten a 7975g to work with asterisk?

My sip firmware is 9-3-1sr2 (have tried 8.5(4) as well) and getting 401 responses. The odd thing is that if i take the phone to home office, it registers without issue. But there is no nat when the phone is at the remote office.

asterisk server is 192.168.10.51
VoIP Phone is 192.168.4.101
Asterisk router is 192.168.10.1 (vpn focal point for remote office)
office router is 192.168.4.1. All traffic is back-hauled over the vpn connection to the asterisk router.

I do have a nat translation in place for our one sip trunk provider that does not support registrations, only through the traffic towards our public IP

ip nat inside source static udp 192.168.10.51 5060 5060 extendable

[314]
deny=0.0.0.0/0.0.0.0
secret=cisco123
dtmfmode=rfc2833
canreinvite=no
context=from-internal
host=dynamic
trustrpid=yes
sendrpid=no
type=friend
nat=no
port=5060
qualify=yes
qualifyfreq=60
transport=udp,tcp,tls
encryption=no
callgroup=
pickupgroup=
dial=SIP/314
[email protected]
permit=0.0.0.0/0.0.0.0
callerid=Mian Home Office <314>
callcounter=yes
faxdetect=no
cc_monitor_policy=generic

— SIP read from UDP:192.168.4.101:52709 —>
REGISTER sip:192.168.10.51 SIP/2.0

Via: SIP/2.0/UDP 192.168.4.101:52709;branch=z9hG4bKa4c6295c

From: sip:[email protected];tag=64168dbb8f89000a05d835c4-60e5726c

To: sip:[email protected]

Call-ID: [email protected]

Max-Forwards: 70

Date: Sat, 08 Jun 2013 21:04:32 GMT

CSeq: 106 REGISTER

User-Agent: Cisco-CP7975G/9.3.1

Contact: sip:[email protected]:52709;transport=udp;+sip.instance=“urn:uuid:00000000-0000-0000-0000-64168dbb8f89”;+u.sip!devicename.ccm.cisco.com=“SEP64168DBB8F89”;+u.sip!model.ccm.cisco.com=“437”

Supported: replaces,join,sdp-anat,norefersub,resource-priority,extended-refer,X-cisco-callinfo,X-cisco-serviceuri,X-cisco-escapecodes,X-cisco-service-control,X-cisco-srtp-fallback,X-cisco-monrec,X-cisco-config,X-cisco-sis-6.0.0,X-cisco-xsi-8.5.1

Content-Length: 0

Reason: SIP;cause=200;text=“cisco-alarm:14 Name=SEP64168DBB8F89 Load=SIP75.9-3-1SR2-1S Last=cm-closed-tcp”

Expires: 3600

<------------->
— (14 headers 0 lines) —

e[Kmypbx*CLI>
e[0KSending to 192.168.4.101:52709 (NAT)

<— Transmitting (no NAT) to 192.168.4.101:52709 —>
SIP/2.0 401 Unauthorized

Via: SIP/2.0/UDP 192.168.4.101:52709;branch=z9hG4bKa4c6295c;received=192.168.4.101

From: sip:[email protected];tag=64168dbb8f89000a05d835c4-60e5726c

To: sip:[email protected];tag=as6bb8ecd8

Call-ID: [email protected]

CSeq: 106 REGISTER

Server: FPBX-2.10.1(1.8.20.1)

Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH

Supported: replaces, timer

WWW-Authenticate: Digest algorithm=MD5, realm=“asterisk”, nonce=“72ada788”

Content-Length: 0

i have added a sip proxy server (siproxd) based off of http://www.freepbx.org/forum/freepbx/users/cisco-7960-7940-sip-fails-to-register-401-403

Im still getting a 403. I also read that the cisco phone does md5 and that I should add the md5 in the password section. That has also not worked.

I suggets baby steps, get it working with UDP signaling before you venture into TCP and TLS.

sorry im not sure what you mean by that?

You are attempting to use tcp to register the phone “transport=udp,tcp,tls” , it is not working.

Thanks!

I changed it… Still 401

[314]
deny=0.0.0.0/0.0.0.0
secret=cisco123
dtmfmode=rfc2833
canreinvite=no
context=from-internal
host=dynamic
trustrpid=yes
sendrpid=no
type=friend
nat=no
port=5060
qualify=yes
qualifyfreq=60
transport=udp
encryption=no
callgroup=
pickupgroup=
dial=SIP/314
[email protected]
permit=0.0.0.0/0.0.0.0
callerid=Mian Home Office <314>
callcounter=yes
faxdetect=no
cc_monitor_policy=generic

<— SIP read from UDP:192.168.4.101:50199 —>
REGISTER sip:192.168.10.51 SIP/2.0
Via: SIP/2.0/UDP 192.168.4.101:50199;branch=z9hG4bKc9f62411
From: sip:[email protected];tag=64168dbb8f890005b04ea24b-0ca0637d
To: sip:[email protected]
Call-ID: [email protected]
Max-Forwards: 70
Date: Tue, 05 Feb 2013 02:01:00 GMT
CSeq: 102 REGISTER
User-Agent: Cisco-CP7975G/9.3.1
Contact: sip:[email protected]:50199;transport=udp;+sip.instance=“urn:uuid:00000000-0000-0000-0000-64168dbb8f89”;+u.sip!devicename.ccm.cisco.com=“SEP64168DBB8F89”;+u.sip!model.ccm.cisco.com="437"
Supported: replaces,join,sdp-anat,norefersub,resource-priority,extended-refer,X-cisco-callinfo,X-cisco-serviceuri,X-cisco-escapecodes,X-cisco-service-control,X-cisco-srtp-fallback,X-cisco-monrec,X-cisco-config,X-cisco-sis-6.0.0,X-cisco-xsi-8.5.1
Content-Length: 0
Reason: SIP;cause=200;text="cisco-alarm:14 Name=SEP64168DBB8F89 Load=SIP75.9-3-1SR2-1S Last=cm-closed-tcp"
Expires: 3600

<------------->
— (14 headers 0 lines) —
Sending to 192.168.4.101:50199 (no NAT)

<— Transmitting (no NAT) to 192.168.4.101:50199 —>
SIP/2.0 401 Unauthorized
Via: SIP/2.0/UDP 192.168.4.101:50199;branch=z9hG4bKc9f62411;received=192.168.4.101
From: sip:[email protected];tag=64168dbb8f890005b04ea24b-0ca0637d
To: sip:[email protected];tag=as213ebce3
Call-ID: [email protected]
CSeq: 102 REGISTER
Server: FPBX-2.10.1(1.8.20.1)
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH
Supported: replaces, timer
WWW-Authenticate: Digest algorithm=MD5, realm=“asterisk”, nonce="46e5fbdd"
Content-Length: 0

does anyone have an idea as to what i can try?

Was this ever fixed?

no it was not. We moved off this software as an end result.