Cisco 7975 - Unprovisioned


(United Kingdom) #1

Evening, wonder if you could help with my Cisco 7975 connecting to version FreePBX 15.0.17.24, PBX server is on 192.168.5.259 and the phones are on 192.168.30.0/24

I’m using SiP ver 8-5-4 on my 7975 with the following XML

     <device>
        <fullConfig>true</fullConfig>
        <deviceProtocol>SIP</deviceProtocol>
        <sshUserId>admin</sshUserId>
        <sshPassword>cisco</sshPassword>
        <devicePool>
            <dateTimeSetting> 
                <dateTemplate>D.M.Y</dateTemplate> 
                <timeZone>GMT Standard/Daylight Time</timeZone> 
                <ntps> 
                    <ntp>
                        <name>0.uk.pool.ntp.org</name> 
                        <ntpMode>Unicast</ntpMode> 
                    </ntp>
                </ntps>
            </dateTimeSetting>
            <callManagerGroup>
                <tftpDefault>true</tftpDefault>
                <members>
                    <member priority="0">
                        <callManager>
                            <ports>
                                <ethernetPhonePort>2000</ethernetPhonePort>
                                <sipPort>5060</sipPort>
                                <securedSipPort>5061</securedSipPort>
                            </ports>
                            <processNodeName>192.168.5.249</processNodeName>
                        </callManager>
                    </member>
                </members>
            </callManagerGroup>
        </devicePool>
        <commonProfile>
            <phonePassword></phonePassword>
            <backgroundImageAccess>true</backgroundImageAccess>
            <callLogBlfEnabled>0</callLogBlfEnabled>
        </commonProfile>
        <loadInformation>SIP75.8-5-4S</loadInformation>
        <vendorConfig>
            <disableSpeaker>false</disableSpeaker>
            <disableSpeakerAndHeadset>false</disableSpeakerAndHeadset>
            <pcPort>0</pcPort>
            <settingsAccess>1</settingsAccess>
            <garp>0</garp>
            <voiceVlanAccess>0</voiceVlanAccess>
            <videoCapability>0</videoCapability>
            <autoSelectLineEnable>0</autoSelectLineEnable>
            <daysDisplayNotActive>1,7</daysDisplayNotActive>
            <displayOnTime>10:30</displayOnTime>
            <displayOnDuration>06:05</displayOnDuration>
            <displayIdleTimeout>00:05</displayIdleTimeout> 
            <webAccess>0</webAccess>
            <spanToPCPort>1</spanToPCPort>
            <loggingDisplay>1</loggingDisplay>
            <loadServer></loadServer>
        </vendorConfig>
        <userLocale>
            <name>United_Kingdom</name>
            <uid>1</uid>
            <langCode>en_US</langCode>
            <version>1.0.0.0-1</version>
            <winCharSet>iso-8859-1</winCharSet>
        </userLocale>
        <networkLocale>United_Kingdom</networkLocale> 
        <networkLocaleInfo> 
            <name>United_Kingdom</name> 
            <uid>64</uid> 
            <version>1.0.0.0-1</version> 
        </networkLocaleInfo> 
        <deviceSecurityMode>1</deviceSecurityMode>
        <authenticationURL>http://192.168.5.249/xmlservices/authentication.php</authenticationURL>
        <directoryURL>http://192.168.249/xmlservices/PhoneDirectory.php</directoryURL>
        <idleTimeout>0</idleTimeout>
        <idleURL></idleURL>
        <informationURL>http://192.168.5.249/xmlservices/index.php</informationURL>
        <messagesURL></messagesURL>
        <proxyServerURL></proxyServerURL>
        <servicesURL>http://192.168.5.249/xmlservices/index.php</servicesURL>
        <dscpForSCCPPhoneConfig>96</dscpForSCCPPhoneConfig>
        <dscpForSCCPPhoneServices>0</dscpForSCCPPhoneServices>
        <dscpForCm2Dvce>96</dscpForCm2Dvce>
        <transportLayerProtocol>4</transportLayerProtocol>
        <capfAuthMode>0</capfAuthMode>
        <capfList>
            <capf>
                <phonePort>3804</phonePort>
            </capf>
        </capfList>
        <certHash></certHash>
        <encrConfig>false</encrConfig>
        <sipProfile>
            <sipProxies>
                <backupProxy>192.168.5.249</backupProxy>
                <backupProxyPort>5060</backupProxyPort>
                <emergencyProxy></emergencyProxy>
                <emergencyProxyPort></emergencyProxyPort>
                <outboundProxy></outboundProxy>
                <outboundProxyPort></outboundProxyPort>
                <registerWithProxy>true</registerWithProxy>
            </sipProxies>
            <sipCallFeatures>
                <cnfJoinEnabled>true</cnfJoinEnabled>
                <callForwardURI>x--serviceuri-cfwdall</callForwardURI>
                <callPickupURI>x-cisco-serviceuri-pickup</callPickupURI>
                <callPickupListURI>x-cisco-serviceuri-opickup</callPickupListURI>
                <callPickupGroupURI>x-cisco-serviceuri-gpickup</callPickupGroupURI>
                <meetMeServiceURI>x-cisco-serviceuri-meetme</meetMeServiceURI>
                <abbreviatedDialURI>x-cisco-serviceuri-abbrdial</abbreviatedDialURI>
                <rfc2543Hold>true</rfc2543Hold>
                <callHoldRingback>2</callHoldRingback>
                <localCfwdEnable>true</localCfwdEnable>
                <semiAttendedTransfer>true</semiAttendedTransfer>
                <anonymousCallBlock>2</anonymousCallBlock>
                <callerIdBlocking>0</callerIdBlocking>
                <dndControl>0</dndControl>
                <remoteCcEnable>true</remoteCcEnable>
            </sipCallFeatures>
            <sipStack>
                <sipInviteRetx>6</sipInviteRetx>
                <sipRetx>10</sipRetx>
                <timerInviteExpires>180</timerInviteExpires>
                <timerRegisterExpires>3600</timerRegisterExpires>
                <timerRegisterDelta>5</timerRegisterDelta>
                <timerKeepAliveExpires>120</timerKeepAliveExpires>
                <timerSubscribeExpires>120</timerSubscribeExpires>
                <timerSubscribeDelta>5</timerSubscribeDelta>
                <timerT1>500</timerT1>
                <timerT2>4000</timerT2>
                <maxRedirects>70</maxRedirects>
                <remotePartyID>false</remotePartyID>
                <userInfo>None</userInfo>
            </sipStack>
            <autoAnswerTimer>1</autoAnswerTimer>
            <autoAnswerAltBehavior>false</autoAnswerAltBehavior>
            <autoAnswerOverride>true</autoAnswerOverride>
            <transferOnhookEnabled>true</transferOnhookEnabled>
            <enableVad>false</enableVad>
            <preferredCodec>g711u</preferredCodec>
            <dtmfAvtPayload>101</dtmfAvtPayload>
            <dtmfDbLevel>3</dtmfDbLevel>
            <dtmfOutofBand>avt</dtmfOutofBand>
            <alwaysUsePrimeLine>false</alwaysUsePrimeLine>
            <alwaysUsePrimeLineVoiceMail>false</alwaysUsePrimeLineVoiceMail>
            <kpml>3</kpml>
            <stutterMsgWaiting>1</stutterMsgWaiting>
            <callStats>false</callStats>
            <silentPeriodBetweenCallWaitingBursts>10</silentPeriodBetweenCallWaitingBursts>
            <disableLocalSpeedDialConfig>false</disableLocalSpeedDialConfig>
            <startMediaPort>16384</startMediaPort>
            <stopMediaPort>32766</stopMediaPort>
            <voipControlPort>5060</voipControlPort>
            <dscpForAudio>184</dscpForAudio>
            <ringSettingBusyStationPolicy>0</ringSettingBusyStationPolicy>
            <dialTemplate>dialplan.xml</dialTemplate>
            <phoneLabel>Chetnet LTD </phoneLabel>
            <natEnabled>true</natEnabled>
            <sipLines>
                <line button="1">
                    <featureID>9</featureID>
                    <featureLabel>Martyn</featureLabel>
                    <name>001FCA368894</name>
                    <displayName>Martyn</displayName>
                    <contact>CONTACT</contact>
                    <proxy>192.168.5.249</proxy>
                    <port>5060</port>
                    <autoAnswer>
                        <autoAnswerEnabled>2</autoAnswerEnabled>
                    </autoAnswer>
                    <callWaiting>3</callWaiting>
                    <authName>3000</authName>
                    <authPassword>12341234</authPassword>
                    <sharedLine>false</sharedLine>
                    <messageWaitingLampPolicy>1</messageWaitingLampPolicy>
                    <messagesNumber>*97</messagesNumber>
                    <ringSettingIdle>4</ringSettingIdle>
                    <ringSettingActive>5</ringSettingActive>
                    <forwardCallInfoDisplay>
                        <callerName>true</callerName>
                        <callerNumber>false</callerNumber>
                        <redirectedNumber>false</redirectedNumber>
                        <dialedNumber>true</dialedNumber>
                    </forwardCallInfoDisplay>
                </line>
            </sipLines>
        </sipProfile>
    </device>

I’m getting an IP address and the phone is grabbing the XML from my TFTP server but it just sits there saying Unprovisioned.

pbx

Thanks


(Shahin Nazir) #2

Hi @chet
Pls check this links, quite similar issues.
https://community.freepbx.org/t/freepbx-12-cisco-7975/25813
https://community.freepbx.org/t/cisco-7975-and-freepbx/67737

Missing ip digit 192.168.5.249
<directoryURL>http://192.168.249/xmlservices/PhoneDirectory.php</directoryURL>


(United Kingdom) #3

Thanks for the response, I’ve followed those prior to posting, thanks for pointing out the directory IP too


(United Kingdom) #4

Now getting SIP/2.0 401 Unauthorized


#5

Under <line button="1"> both name and authName should be the extension number.


(United Kingdom) #6

Think it may be a NAT issue

This is a working Cisco SPA
<— Transmitting (NAT) to 192.168.30.4:5060 —>
SIP/2.0 200 OK
Via: SIP/2.0/UDP 192.168.30.4:5060;branch=z9hG4bK-3b1f8256;received=192.168.30.4;rport=5060
From: “Chet” sip:2000@192.168.5.249;tag=5e3c8ef1d4c1563o0
To: sip:192.168.5.249;tag=as6ac65ab0
Call-ID: 6059dac9-881f7b6b@192.168.30.4
CSeq: 273 NOTIFY
Server: FPBX-15.0.17.24(16.15.1)
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH, MESSAGE
Supported: replaces, timer
Content-Length: 0

This is the 7975
<— Transmitting (NAT) to 192.168.30.5:49219 —>
SIP/2.0 401 Unauthorized
Via: SIP/2.0/UDP 192.168.30.5:5060;branch=z9hG4bK333f11da;received=192.168.30.5;rport=49219
From: sip:001FCA368894@192.168.5.249;tag=a8b1d4faefb50003b8ef10db-3a4d9740
To: sip:001FCA368894@192.168.5.249;tag=as13e0aefd
Call-ID: a8b1d4fa-efb50003-11feaaad-1c8a4d6e@192.168.30.5
CSeq: 101 REGISTER
Server: FPBX-15.0.17.24(16.15.1)
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH, MESSAGE
Supported: replaces, timer
WWW-Authenticate: Digest algorithm=MD5, realm=“asterisk”, nonce=“7fc2ffc3”
Content-Length: 0


#7

In Asterisk SIP Settings, set Local Networks to 192.168.0.0 / 16 , Submit, Apply Config, restart Asterisk, test.

If you still have trouble, please explain: Why are you using chan_sip? By default, pjsip listens on UDP port 5060 and chan_sip is on 5160. Did you change these? If so, why?


(United Kingdom) #8

Hi Stewart1, I have 192.168.5.0/24 and 192.168.30.0/24 in my Asterisk SIP setting.

Changed the default because I had issues connecting to my SIP provider sipgate.com

Thanks


#9

In sipLines, Name should be 3000 (match the extension number).

Please explain any routing or firewall between phone and PBX. If NAT is involved, you may be out of luck.


(United Kingdom) #10

I already have a Cisco phone registered (SPA504G) which works fine, I fully appreciate though that this is a SIP phone and not one whose sole purpose is to work with CUCM, guess I’m out of luck then.

What I’m trying to figure out is why the ports are different and what’s changing it.

Working phone
Transmitting (NAT) to 192.168.30.4:5060

None working phone
Transmitting (NAT) to 192.168.30.5:49219


#11

I don’t understand why Asterisk is not sending to the port specified by the Via header.

Confirm that you have NAT Mode for the extension set to Never and there is no actual NAT between the 192.168.5 and 192.168.30 subnets. Also that you have restarted Asterisk after modifying Local Networks, and that in the XML you have changed (in sipLines) name to 3000.

If you still have trouble, post the section of sip_additional.conf for the extension in question.