Cisco 7960G outbound calls


(Justlie) #1

Hi,

I have a Raspberry Pie 3 B+ setup with freepbx and was able to get the Cisco 7960G registered and its
able to receive inbound calls. However, I am having issues making calls on the 7960G. The phone is running firmware SIP45.8-5-4S. The secret is 8 characters long with simple lowercase chars and numerics. All i get is the number is not in service announcement.

Here are some things I noticed:

  1. Under sip show users, the phone with extension 201 is showing up and has the default context from-internal

Username Secret Accountcode Def.Context ACL Forcerport
201 ***** from-internal Yes No

  1. under sip show peers, the phone is showing up with status OK (28ms)

Name/username Host Dyn Forcerport Comedia ACL Port Status Description
201/201 192.168.15.46 D No No A 5060 OK (28 ms)

Here is the actual issue from the log when I make a call:

Executing [1**********@from-sip-external:1] NoOp(“SIP/192.168.15.40-00000009”, “Received incoming SIP connection from unknown peer to 1**********”) in new stack

Executing [s@from-sip-external:7] Log(“SIP/192.168.15.40-00000009”, "WARNING,“Rejecting unknown SIP connection from 192.168.15.46"”) in new stack

.40 is the freepbx server
.46 is the phone

Why is it saying that the call is coming from external? Shouldn’t it be from-internal since its coming from a known extension/internal IP?

Any idea what to check to do next to troubleshoot this issue?


(Dave Burgess) #2

Sounds like you’re connecting the phone to the wrong channel driver. Check to make sure that your Extension is setup as a “PJ-SIP” extension (not chan_sip) and that your phone’s config is pointed to the right port and address.

Also, in the “Advanced Settings -> SIP Settings -> General” tab has the local network listed and that the Integrated Firewall is set up correctly.

The clue is that the call is being identified as an “anonymous” call, which means there’s no local connection to the extension.


(Sam90) #3

Hi,

Double check your SEP.cnf.xml has

<sipPort>5160</sipPort>

in the “device -> callManagerGroup -> members -> member -> callManager -> ports” section, so long as you are using the chan_SIP driver on the default chan_SIP port (5160).


(system) closed #4

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.