Cisco 7960 phone no audio

Just upgraded to the latest Freepbx x64 Stable-6.12.65 with Asterisk 13. The Polycom phones work just fine. The Cisco 7960 phone somehow doe not work. If I provision the extension with PJSIP, the phone won’t register in the PBX at all. If I provision the extension with CHAN_SIP, the phone registers in the PBX and appears to be online. I can call the Cisco phone from the Polycom phone and the Cisco phone rings and I can pickup the call. However, he audio is only one way from Polycom to Cisco. Speak to the Cisco phone but no audio out from Polycom. Samething happen when the Cisco phone calling Polycom phone or calling outside line. The DTMF also not working. Dial 7777 from the Cisco phone and it won’t accept any key press. I set the extension NAT mode to “No” or “Never” with no affect. It was working with Asterisk 11 in Freepbx version 5.xx. Is the Asterisk 13 no longer supporting Cisco 79xx phone or somewhere in the SIP setting needs to be adjusted?

Post your 7960 xml config for us. Also, is your 7960 on the same LAN as freepbx? And is polycom on same LAN as well?

The Cisco 7960 phone doesn’t use XML config file. It uses SIP.cnf file. The PBX is in a seperate network from the phones network over vpn. The phones are in a same VLAN network.

Oh okay, post the phones .cfgs so we can check it out

Here is the phone config file.

proxy1_address: ""
proxy2_address: ""
proxy3_address: ""
proxy4_address: ""
proxy5_address: ""
proxy6_address: ""
line1_name: "101"
line1_shortname: "101"
line1_displayname: "101"
line1_authname: "101"
line1_password: "xxxxxxxxxxxxxxx"
line2_name: ""
line2_shortname: ""
line2_displayname: ""
line2_authname: ""
line2_password: ""
line3_name: ""
line3_shortname: ""
line3_displayname: ""
line3_authname: ""
line3_password: ""
line4_name: ""
line4_shortname: ""
line4_displayname: ""
line4_authname: ""
line4_password: ""
line5_name: ""
line5_shortname: ""
line5_displayname: ""
line5_authname: ""
line5_password: ""
line6_name: ""
line6_shortname: ""
line6_displayname: ""
line6_authname: ""
line6_password: ""
proxy_emergency: ""
proxy_emergency_port: "5060"
proxy_backup: ""
proxy_backup_port: "5060"
outbound_proxy: ""
outbound_proxy_port: "5060"
nat_enable: "0"
nat_address: ""
voip_control_port: "5060"
start_media_port: "16348"
end_media_port: "20134"
nat_received_processing: "0"
time_zone: "PST"
logo_url: ""
telnet_level: "2"
phone_prompt: "CiscoCP7960"
phone_password: "222222"
enable_vad: "0"
network_media_type: "auto"
user_info: "phone"
sntp_mode: "directedbroadcast"
sntp_server: ""
time_format_24hr: "0"
dst_offset: "1"
dst_start_month: "April"
dst_start_day: ""
dst_start_day_of_week: "Sun"
dst_start_week_of_month: "1"
dst_start_time: "2"
dst_stop_month: "Nov"
dst_stop_day: "1"
dst_stop_day_of_week: "Sunday"
dst_stop_week_of_month: ""
dst_stop_time: "2"
dst_auto_adjust: "1"
proxy1_address: ""
proxy2_address: ""
proxy3_address: ""
proxy4_address: ""
proxy5_address: ""
proxy6_address: ""
proxy1_port: "5060"
proxy2_port: ""
proxy3_port: ""
proxy4_port: ""
proxy5_port: ""
proxy6_port: ""
proxy_register: "1"
timer_register_expires: "3600"
preferred_codec: "none"
cnf_join_enable: "1"
semi_attended_transfer: "1"
dtmf_inband: "1"
dtmf_db_level: "3"
timer_t1: "500"
timer_t2: “4000”
sip_retx: "10"
sip_invite_retx: "6"
timer_invite_expires: "180"
messages_uri: "*97"
dnd_control: "0"
callerid_blocking: "0"
anonymous_call_block: "0"
call_waiting: "1"
dtmf_avt_payload: "101"
dial_template: "dialplan"
autocomplete: "1"
services_url: ""
directory_url: ""
logo_url: ""
phone_label: “101”

Hey Jing,
Ive had this problem before also.

It is because the 7960 is not on the same LAN as the freepbx server. NAT settings need to be configured in the phone config file.

Also freepbx settings:

  • NAT set to Yes on freepbx extension settings.
  • under SIP settings, you have to configure the local networks and external IP.

I am looking into the 7960 nat settings and will post back

For the 7960 config NAT settings, try this

nat_enable: "1"
nat_address: “set this as the VPN address that it is NATd to, for my config below”

For example, i used openvpn in Routing mode:

Phone IP:
VPN IP site 1:

VPN IP hq site:
Freepbx server IP:

I realize this is a very old post. It also happens to be the first one in a google search for “7960 no audio”, so hopefully this will help others.

rchase nailed it, but it requires more detail. If you’re behind a firewall with your 79xx phone and trying to connect to a paid public VOIP service, the correct settings will be:

nat_enable: “1”
nat_address: “your EXTERNAL IP address, as seen by the internet”

Reboot the phone and it will register as if NAT is not enabled, even though the 79xx will still have a private IP address. Your audio will then work perfectly.

These 79xx phones will not work properly when NATting without that setting enabled. Believe me, I tried everything in the last 24 hours to get these phones to work with OnSip. I finally got them registering, but incoming calls had no audio. Outgoing calls worked perfectly, strangely enough.