Cisco 7940/7940G End Point Configuration Manager Isssue

After searching the forums closely, specifically this post:

I am still having difficult using the End Point Configuration Manager to correctly/actively manage the phones.

Here is the information for the setup:
Asterisk (Ver. 11.2.1)
Description for version
All Phones have latest SIP Firmware of P0S3-9-12-00

System works correctly with Softphone and Google Voice. Trying to get cisco 7490G phones to work. Which based on the post above may be able to be treated simiarly.

First, issue was that the Cisco phones were not found when trying to search for devices. 000164 was present, but not 001646 (MAC for first phone is 001646A18204) in the OUI Manager.

After added the appropriate information to the OUI Manager the phone would show in the list of Unmanaged Extensions. Select phone map to an extension and select add selected phone. I would then manually reboot the phone. I turned on tftp logging to verify data is being pulled and it appears it is from the log below:
Mar 5 01:42:40 rccpbx in.tftpd[5933]: RRQ from filename SEP001646A18204.cnf.xml
Mar 5 01:42:40 rccpbx in.tftpd[5934]: RRQ from filename P0S3-8-12-00.loads
Mar 5 01:42:40 rccpbx in.tftpd[5934]: sending NAK (1, File not found) to
Mar 5 01:42:58 rccpbx in.tftpd[5938]: RRQ from filename SIPDefault.cnf
Mar 5 01:42:58 rccpbx in.tftpd[5939]: RRQ from filename ./SIP001646A18204.cnf
Mar 5 01:43:01 rccpbx in.tftpd[5940]: RRQ from filename RINGLIST.DAT
Mar 5 01:43:01 rccpbx in.tftpd[5941]: RRQ from filename dialplan.xml

However, the phone doesnt show the new/updated extension as one of the lines and if I use the 7940G in End Point Connection Manager the phone searches for the SIP001646A18204.cnf and never find the file.

Everything is within the same network, I have also tried turning off Fail2Ban and Iptables for testing purposes only and that made no difference as well.

I assume the 9.12 software is a typo, the last version was 8.12 and that is what the phone is requesting.

Not sure what you are doing wrong. Please post a list of the contents of /tftpboot ‘ls -l /tftpboot’ and the contents of ‘cat /tftpboot/SIP001646A18204.cnf’

Please use the [code]tags[/code] so we can easily read your posts.

Sorry, it has been a long night trying to figure this out. Yes, the firmware is P0S3-8-12-00.

Here is the information you requested.

drwxr-xr-x 2 asterisk asterisk  12288 Mar  5 02:14 config_bkup
-rw-r--r-- 1 asterisk asterisk     14 Mar  5 01:57 OS79XX.TXT
-rw-r--r-- 1 asterisk asterisk 130552 Mar  5 01:57 P003-8-12-00.bin
-rw-r--r-- 1 asterisk asterisk 130956 Mar  5 01:57 P003-8-12-00.sbn
-rw-r--r-- 1 asterisk asterisk    458 Mar  5 01:57 P0S3-8-12-00.loads
-rw-r--r-- 1 asterisk asterisk 756524 Mar  5 01:57 P0S3-8-12-00.sb2
-rwxrwxr-x 1 asterisk asterisk    202 Mar  5 01:59 RINGLIST.DAT
-rwxrwxr-x 1 asterisk asterisk      0 Mar  5 01:59 ringlist.xml
-rwxrwxr-x 1 asterisk asterisk    611 Mar  5 02:14 SEP001646A18204.cnf.xml
-rwxrwxr-x 1 asterisk asterisk   1393 Mar  5 02:14 SIP001646A18204.cnf
-rwxrwxr-x 1 asterisk asterisk    403 Mar  5 02:14 SIPDefault.cnf
-rwxrwxr-x 1 asterisk asterisk   1563 Mar  5 02:14 XMLDefault.cnf.xml

phone_label: "Test User 2 "

line1_name: "702"
line1_shortname: "Test User 2"
line1_displayname: "Test User 2"
line1_authname: "702"
line1_password: "Removed"

messages_uri: "*97"

proxy1_address: ""

proxy_emergency: ""
proxy_emergency_port: "5060"
proxy_backup: ""
proxy_backup_port: "5060"
outbound_proxy: ""
outbound_proxy_port: "5060"

proxy_register: "1"
timer_register_expires: "120"
preferred_codec: "none"
tos_media: "5"
enable_vad: "0"
dial_template: "dialplan"
network_media_type: "auto"
autocomplete: "1"
telnet_level: "2"

nat_enable: "0"
nat_address: ""
voip_control_port: "5060"
start_media_port: "16348"
end_media_port:  "20134"
nat_received_processing: "0"
dyn_dns_addr_1: ""
dyn_dns_addr_2: ""
dyn_tftp_addr: ""
tftp_cfg_dir: "./"

time_zone: PST
sntp_mode: "directedbroadcast"
sntp_server: ""
time_format_24hr: "1"
dst_offset: "1"
dst_start_month: "March"
dst_start_day: ""
dst_start_day_of_week: "Sun"
dst_start_week_of_month: "2"
dst_start_time: "2"
dst_stop_month: "Nov"
dst_stop_day: ""
dst_stop_day_of_week: "Sunday"
dst_stop_week_of_month: "1"
dst_stop_time: "2"
dst_auto_adjust: "1"

services_url: ""
directory_url: ""
logo_url: ""

telnet_level: "2"
phone_prompt: "Cisco7960"
phone_password: ""
enable_vad: "0"
network_media_type: "auto"
user_info: phone

Figured out how to turn on additional logging for the asterisk server. I found this in the log files

[2013-03-05 02:35:58] NOTICE[2034] chan_sip.c: Registration from '<sip:[email protected]>' failed for '' - Wrong password
[2013-03-05 02:35:58] VERBOSE[2034] chan_sip.c: Scheduling destruction of SIP dialog '[email protected]' in 32000 ms (Method: REGISTER)
[2013-03-05 02:36:01] VERBOSE[2034] chan_sip.c:

I am absolutely certain that the secret phrase from the extension matches the content of the line1_password.

Still not sure exactly what the problem is, but I can confirm that it appears some of the SIP configuration information is loading correctly. I tried changing the extension name and added logo url to verify. Both changes were reflected appropriately. I have tried restarting the asterisk portal just to make sure it wasnt an issue.

Making some progress. Based on what I read in another forum post, I manually changed the secret phrase for my test extension to 1234abcd. Saved, applied, rebuilt phone configs, and manually rebooted phones. This seemed to solve the problem and was able to make text calls and retrieve test voice mail. Not sure why it worked, but that change fixed the major issue.

Minor issue that End Point Connection Manager still shows device off line and dosen’t “force” the phones to reboot when changes are made.

I had that same thing happen to me recently. If you put too long of a extension secret for the cisco 79X0 phones it wont register. Also I noticed that some special characters will cause the same thing to happen.