Cisco 3905 Configuration

Hi all

I know this isn’t strictly the right forum, but the Cisco Community Forums weren’t any help so I’m hoping someone over here has an answer, or at least suggestions.

I’ve got a Cisco 3905 phone that’s almost perfectly working with FreePBX. The one problem is that it has a 10 second delay before it dials any valid numbers. Invalid numbers (i.e. not in the dialplan) are rejected right away, but anything valid has this delay of ten seconds. After that point it dials and things work perfectly. I’m convinced it’s an XML setting that needs to be changed.

I was just wondering if anyone is successfully using the 3905 with Freepbx/Asterisk, and if so what your config XML looks like. I know my dialplan is fine as all other phones (mostly 79xx series) work flawlessly. And even this 3905 is following the dialplan. It just has a strange ten second delay before it actually dials any valid number.

Any and all help is appreciated. The people over at the cisco forums were stumped.


Probably this won’t help you, but it sounds as if the configured inter-digit timeout is set to 10 seconds and the dial plan is still waiting to match a number, and that is why after the 10 seconds pass, your number gets dialed.

I don’t think that’s it, but I’d like to try regardless. Do you know where you can specify the timeout in the config files?

I’m quite sure it is that, all “real” cisco phones have the 10 seconds inter digit timeout as default if the number doesn’t match the dial plan.

The only thing I could find is this, but I’m not sure whether it will work for you

<TEMPLATE MATCH="…" Timeout=“0”/>

My current dialplan looks like this:

    <TEMPLATE MATCH="0.." TIMEOUT="0" User="Phone"/>
    <TEMPLATE MATCH="1.." TIMEOUT="0" User="Phone"/>
    <TEMPLATE MATCH="\*.." TIMEOUT="0" User="Phone"/>
    <TEMPLATE MATCH="7..." TIMEOUT="0" User="Phone"/>

I believe that is all correct. Any number that does not match the above templates immediately goes to a disconnected tone. Anything valid from the above list, however, waits 10 seconds despite the timeout set in the dialplan. Let me know if you see anything glaring but this same dialplan works on all other phones on the system without issues.

Thanks for giving me some guidance.

I’ve not worked with this particular phone before, but it looks like your phone is set up to immediately dial “0xx” “1xx” “*xx” and “7xxx”, (where ‘x’ is a digit) correct? If that’s the case, how do you call for pizza?

Typically (based on experience and lots of prior art) there are a couple of ways we dodge this. One is “predialing”. SIP doesn’t send single digits - it sends an entire message. Because of this, it builds whatever number you are trying to call into a message in the phone and fires it off once it’s sure you’re done pushing buttons. That’s what the 10-second pause is for. So, predial your number and press “Dial” or pick up the handset. It “should” (hopefully) dial the entire number on that event and away you go.

There’s also commonly a ‘dial terminator’ character (usually “#”) that can be used to tell the phone you are ready to go. So, dial 8005551212# and the call should initiate.

Finally, in your dialtemplate (if you live in the North American Number Plan - NANP), you could try adding ‘MATCH=".........."’ and see what happens and have everyone dial all ten digits.

Well first off it’s a local-only system. I don’t have (at least for now) a trunk to the PTN and it’s mostly used for my coworkers and I to talk to each other. It all started when someone brought in a few surplus phones and it’s been evolving ever since. Those templates are for our extension format, plus conference numbers and the FreePBX *xx extensions.

When I’m with the problem phone next I’ll try the # trick. I recall from reading that you typically need to add an entry to the dialplan to make that work. I’ve also never tried dialing a number and then lifting the handset so that could be another potential solution. I typically will get a dialtone first before I try dialing.

Thanks for the suggestions

The dialtone on a SIP phone is locally generated. On some phones, it’s an indication that you have a destination registered. On others, it’s just ‘there’. It won’t actually dial until the phone is sure you’re done.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.