CID via call forwarding

I maintain the VoIP system for my company. We do billing via the FreePBX CDR database. I’ve noticed that if a person enables call forwarding on their phone, the source shows up in the CDR as the incoming call’s CID, not the extension who forwarded as expected. Is there any way for this behavior to be disabled, so we can bill for these kind of calls?

This question comes up very often. Search this site’s postings for changing outgoing CID.

There are many issues surrounding it and it’s totally possible that you can’t (well you can but it will not actually change due to your provider).

Spoofing a CID that you do not own is illegal in the US. So many providers will not allow it.

Best place to start is to contact your provider (you didn’t provide any real info so we don’t know what type of trunks, etc). See if they will allow you to change the CID to a number outside of the range you own. Even if they don’t you should be able to change it and have it show up in your CDR database just not outside.

But like I said this has been asked and address many times.

Let me clarify.

Here are the steps.

  1. 213-111-1111 calls me at 310-222-2222.
  2. Since my phone is autoforwarding to my cell 323-333-3333, asterisk dials an outside line.
  3. I receive a call on my cell, and the CID is 213-111-1111 instead of the expected 310-222-2222.
  4. The CDR also reflects the source 213-111-1111 and destination as 323-333-3333.

My provider (XO) does pass any CID that Asterisk passes to it. Unfortunately, when I’m forwarding a call via my phone (or blind transferring an incoming call to an outside line), it shows the incoming phone number, not my own CID. I’d like for that behavior to change, in both the CID shown, and the CDR records so I can bill correctly.

Sorry I read it wrong you wanted to DISABLE it versus enable it… If you set the CID for your extension it should override it if I remember correctly.

Out provider restricts CID to only the block we own, so I can’t change it here to perform a test and verify it for you.

The CID is set on the extension correctly. When I call manually, it shows up just fine. It’s only when you have no interaction does it start acting weird (blind transfers, autotransfers, followme).

This is the same behavior, on site or off. To test it, just have one of your extensions auto-forward to another extension, and you’ll see what I mean. Or blind transfer to another extension, and it will show the incoming call’s CID, not your extension.

I am experiencing the same behaviour.

I need to have the CID of the outbound (no interaction) transferred call set to the CID that is set on the extension.

Now my system tries to pass on original calling/remote party CID. Which my ITSP, in the outgoing call, replaces with my trunks default number in the 100-block.

Jgrutier, did you ever find a solution?

Nope. No solution for this. We just started using the accountcode field and bill from there, not from the extension’s CID.

For your quick response!
Even though I wished you had something up the sleeve. This functionality should just be there. A configuration setting global or per extension in the GUI.

I can’t imagine you and I alone want this functionality…