Cicso ATA 186 unstable for incoming calls

Running Asterisk with FreePBX 2.10.0 on CentOS 6.2 32-bit. No real issues to report. Trunks work fine, and SIP extensions all work fine with softphones.

I’m experimenting with a Cisco ATA 186. I have it configured as a SIP device for two extensions. The ATA is sitting behind a NAT router. The extensions register just fine and I can make outgoing calls from either extension with no problem. The problem is with receiving incoming calls.

I couldn’t receive incoming calls at all until I enabled anonymous Internet requests in the security section of the NAT router, but after doing that calls started coming in. Unfortunately incoming calls aren’t reliable, in that Asterisk gives a “caller unavailable” message a lot of the time. Sometimes only phone 1 is available, and sometimes it’s only phone 2. Sometimes both are available, and sometimes neither is available. The behavior seems to be related to how the extensions are indicated in the FOP Panel, where they sometimes are half ghosted (not sure what being half ghosted means). However, even when they are half ghosted I can still make outgoing calls through asterisk.

I tried port forwarding 5060-5061 UDP & 10000-20000 UDP to the ATA, with no change. I even tried placing the ATA in the router’s DMZ, still with no better results. I had upgraded the ATA’s firmware to 3.2.0 SIP firmware before starting this project, so I thought maybe the problem was that the firmware was unstable. I downgraded the firmware to 3.1.0 but got no better results. Here is a link to my current settings (proxy IP addresses deliberately munged for image).

I’ve tried configuring it for only one extension, but even a single extension drops in and out on me for incoming calls. Still, it’s 100% solid for outgoing calls.

Clearly, this ATA device isn’t suitable for a production environment of any kind the way it’s performing now. Any advice would be greatly appreciated.

Be certain NAT Keepalive is enabled.

Build a VPN back to your Asterisk/FreePBX box and all your problems will go away.

and if you care to register both your ports on the same IP with the same port (5060) what do you expect, if you look deeply inside you will probably discover that port one prefers 5060 and port two 5061 (that would be a lack of RTFM, as usual, the manuals would include asterisk, networking, your routers and the ata itself)

I’ve already tried port forwarding 5060 & 5061, but it didn’t help. I don’t see how it could have helped, since the ATA only allows one port to be declared (5060 by default).

I stand corrected,


will give you 631 more documents to peruse.

Now that I think about it, when I used this same ATA with Vonage 8 years ago people used to complain that they called me but it went to voicemail. I thought at the time that I might have just stepped out and missed the call, but it may have been acting up back then too.

That seems to indicate that the ATA has always had this problem. I’m wondering if this particular ATA might be defective.

Put the ATA in the same network as the Asterisk box for testing.

If it stays registered then you know it’s a networking problem and you can setup your VPN and stop worrying about it.

That’s not going to happen. Asterisk is installed on a VPS in Chicago, while I’m in Las Vegas, NV.