Choppy audio


#41

How do you have the HyperV network card set up? It’s been a while since I worked with a HyperV system but I always remember there were several ways to handle the virtual network card and IP for the VM. Anything amiss there perhaps?


#42

I have it set up in whatever the default way is for Hyper-V, I guess.

I don’t recall doing anything special when I first set it up. It’s been running for years with the same config without any issues.


(Matthew Fredrickson) #43

If by outbound audio you mean that the person at the other end of the phone call (through the vega gateways) hears choppy audio but the other direction is fine, then I guess you’d want to check to see if there are some kind of jitter buffer settings on the vega (since jitter buffers are typically beneficial on packet reception, particularly in the packet -> TDM direction).

I’m not a vega expert though, so you might have to look at the vega docs and see if there’s a jitter buffer like setting you can set or adjust on it.

Matthew Fredrickson


#44

If you capture the network traffic to a pcap file with tcpdump, you can use the voip menu in wireshark to take a look at the RTP traffic using the RTP Stream Analysis section.


#45

@mattf

I enabled jitter buffer on chan_sip since that’s how I’m connecting to my Vegas, but it had no effect.

I have been unable to find any jitter settings on either of the two Vegas

@nielsen

My RTP debugs showed no abnormalities. I suspect I’d find the same in a tcpdump (and I’m not really qualified to sift through that anyway).


#46

Returning back to this, I was reminded of a setting I had to change on one of my other VM hosts regarding poor network quality and I checked my notes to see what it was.

Virtual Machine Queues

image

I disabled VMQ on the primary NIC in the server and it seems to have cleared up all choppy audio issues (at least for now – I’m still worried the issue will resurface after some time).

I’m not sure why it’s a problem now after all these years, but – fingers crossed – it seems to have fixed the issue.

I’ll follow up in day or two (or less if the problem comes back) with an update.

Thank you all for your help. This community is great!


#47

Is it possible that a Windows update might have changed things?


#48

No, I have Windows Updates disabled on that server. I suspect it was always on (I don’t recall changing it). I’m not sure why it was all of a sudden a problem, but I really don’t care at this point because it’s working. :joy:


(Jared Busch) #49

VMQ is evil. Well because MS screwed up the implementation.


#50

holy crap! I might actually have been useful on this thread :smile:


#51

Yessir! Your post definitely reminded me of that NIC setting and I’m going on 18 hours without a problem so I’m pretty sure that was the fix.

Thanks a ton and thanks again to everyone else for their help.


#52

Welp, nary an issue since the VMQ changes. :grin:


(system) closed #53

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.