Choppy Audio + loss packets & delay on one leg

The setup:

FreePBX distro (same problem occurs with the 64 bits alpha-5.12.65-3/asterisk 12 and with the 64bits stable-

distro running on a server with fixed ip address, firewall disabled (all ports open). Server is on a 100Mbps guaranteed bandwidth connection, there is no packet loss and low ping between the input and output.

Input: DID number routed to the server IP address
Configuration: DISA on DID, then dial out the number entered
Output: SIP Voip Provider (premium quality)

Codec: G711-Alaw (input and output)

- audio prompts, congestion messages & DISA dial tone are very choppy (timing issue?)
- when call is established, audio from source to destination is fine, low delay, good quality. Audio from destination to source is delayed by about 2 seconds, it’s very choppy. I noticed no audio packet is transmitted from destination to source if there is no audio or low level audio, there seems to be a 2 seconds delay (I need to keep talking more than 2 seconds nons top) in order to have audio packets comming in. Analysis shows average of 48 packets/sec on one leg (the good one) and 16/sec on the other (that means many missing packets).

What I have tried already:

  • Checking connectivity
  • Reinstall (tried 2 distro versions)
  • Install on another server (same problem)
  • add clock=pit in grub.conf
  • Enable jitter buffer (didn’t help)
  • Use other codecs (g711-ulaw, g729)
  • Input with SIP instead of DID
  • output directly to a SIP device instead of voip operator
  • Pass through a sip gateway on input/output and forcing RTP relay (no improvement)
  • tried “silenceSuppression=no” in asterisk SIP settings
  • Checked logfiles for error or warnings

If anyone knows what could be causing this, that would really help me.

Thanks in advance.