Checking for updates in the module admin errors out

I’m getting this in my browser when I check for updates. FreePBX version is 1.1010.210.62-5. Hopefully there is a fix.

[code]
Module Administration

FATAL ERROR

XML error: Not well-formed (invalid token) at line 1

Trace Back

/var/www/html/admin/libraries/xml2Array.class.php:50 die_freepbx()
[0]: XML error: Not well-formed (invalid token) at line 1

/var/www/html/admin/libraries/xml2Array.class.php:131 xml2Array->parse()
[0]: HTTP/1.0 302 Found Location: /cgi-bin/ipdiags.ha Pragma: no-cache Content-Type: text/html <meta http-equiv=Refresh content=0;url=/cgi-bin/ipdiags.ha>

/var/www/html/admin/libraries/xml2Array.class.php:34 xml2Array->parseAdvanced()
[0]: HTTP/1.0 302 Found Location: /cgi-bin/ipdiags.ha Pragma: no-cache Content-Type: text/html <meta http-equiv=Refresh content=0;url=/cgi-bin/ipdiags.ha>

/var/www/html/admin/libraries/module.functions.php:86 xml2Array->xml2Array()
[0]: HTTP/1.0 302 Found Location: /cgi-bin/ipdiags.ha Pragma: no-cache Content-Type: text/html <meta http-equiv=Refresh content=0;url=/cgi-bin/ipdiags.ha>

/var/www/html/admin/page.modules.php:161 module_getonlinexml()

/var/www/html/admin/config.php:333 include()
[0]: /var/www/html/admin/page.modules.php[/code]

AT&T DSL is the problem. The phone calls go through, but if you wget a few websites on the internet they download like this. Thanks for wasting an hour of my time AT&T.

[code][[email protected] tmp]# cat index.html

AT&T GUI [[email protected] tmp]# cat repomd.xml HTTP/1.0 302 Found Location: /cgi-bin/ipdiags.ha Pragma: no-cache Content-Type: text/html

[[email protected] tmp]#
[/code]