Changing voicemail email template in FreePBX 13

I recently upgraded to FreePBX 13 and I’ve discovered that the voicemail template has changed. The new voicemail message looks like this:

Dear Joe Smith:

Just wanted to let you know you were just left a 0:44 long message (number 1) in mailbox 9791 from TOLL FREE CALLE, on Tuesday, November 17, 2015 at 09:38:35 AM so you might want to check it when you get a chance. Thanks!


How do I switch it back to the old template that looked like this:

Justin Kelly,

There is a new voicemail in mailbox 9801:

From: “TOLL FREE CALLE” <8881234567>
Length: 0:05 seconds
Date: Wednesday, November 11, 2015 at 11:14:48 AM

I tried updating the emailbody variable on the Voicemail settings page to this:


There is a new voicemail in mailbox VM_MAILBOX:

Length: VM_NAME

But I received an error when I submitted the changes. Does anyone know what I may be doing wrong here?

Here is a screenshot of the error page:

Works for me. Please ensure there are no outstanding module updates on the system and confirm what you are using for the body by pasting here between code tags. Of note, the variable place holders you are using are the wrong format, they should be ${VM_CALLERID}.

Thanks for your help Lorne, I was able to get it to work by properly formatting the placeholders as you indicated. Although it still gave the same error until I enclosed the entire message in quotes. So maybe this is a bug?

Here is what worked:


There is a new voicemail in mailbox ${VM_MAILBOX}:

Length:	${VM_DUR}
Date:	${VM_DATE}"