Changing sip port >> trouble?

I’ve read in the forums how to do this, but it isn’t working for me unless i’m not understanding correctly. I’m trying to change from the standard sip port of 5060 to 5160 per the advice from viatalk to resolve some issues i’ve having with some of their servers.

I’m using Asterisk 1.8.8.0 with Freepbx 2.9.0.12 on Ubuntu 11.

I’ve changed the sip port setting in SIP Settings for bindport to be 5160 and made corresponding changes to my phone devices to use that port as well, but would have expected the sip registration to reflect the port change to? Looking at the status below it doesn’t reflect the change despite a restart of amportal.

myserver*CLI> sip show registry
Host dnsmgr Username Refresh State Reg.Time
chicago-1f.vtnoc.net:5060 N 19999999999 105 Registered Thu, 31 May 2012 16:05:10
1 SIP registrations.

What am i missing here? Viatalk wants me to change the port I register with to 5160.

thanks

what does

netstat -an | grep 5060

netstat -an | grep 5160

say?

I think the bind port/IP don’t just change on reload, you gotta amportal kill and amportal start

Trouble for people who do not understand how TCP/IP works :wink:

This should make a helpful reading:
http://www.freepbx.org/forum/freepbx/general-help/sip-port-to-a-non-standard-number