Changing servername in the 401 Unauthorized response message?

Does somebody know if it is possible (and were we can do it) to change the servername, which the FREEPBX sends in there 401 Unauthorized message during registration?

The reason why i ask is that we discover that the termina, which we want to register, doesn’t understand the () in the servername:

The servername which the FREEBPX sends right now is:
Server: FPBX-2.11.0beta2(11.1.2)

therefor it would be quit nice we we can delete the () in the servername.

please advise and thx in advance
Ray

edit /etc/sysconfig/network-scripts/ifcfg-eth0.bak

change the DHCP_HOSTNAME=

The user agent is set in sip_general_additional.conf

useragent=FPBX-2.9.0(1.8.7.1)

I think you will need to change sip_general_custom.conf to override it.

this was indead the solution to change the Useragent in the sip_general_additional.conf

thx a lot!
ray

If you change inside _additional.conf files, it will get replaced when freepbx gets reloaded. Better as suggested use _custom.conf instead.

Best, use the Asterisk SIP settings in FreePBX :slight_smile: