Changed SIP Provider and Followme no longer works

ok the only change we have made is the sip provider, he is also my ISP, so I’m not sure what is going on, but I do have some call traces, so I’m hoping one of you lovely people can tell me where it is going awry.

so my ext is 137, and as you can see a friend of mine calls my number it rings my ext and does a followme to my other phone 714-1505# when I answer the call he can’t hear anything I say and I can’t hear anything he says.
please help!

so no one wants to commit, so how about this, can somoene tell me how follow me is supposed to work.
SIP provider A is our local ISP and SIP provider for Local DID’s Call comes in through SIP provider A, SIP provider B is our Default Outbound route, we get unlimited calls for set pricing, so all calls go out through SIP provider B. Question is since I have swapped over to a new SIP provider, which SIP provider A. when the follow me is activated, and my cell rings neither party can hear the other. So is it a configuration issue, or is it something weird like because they are both going through my router, and not on an internal network like the old SIP provider, the IP is having trouble going back out the default gateway… I know I’m just stabbing in the dark but, really I’m stabbing wildly! help please… #Crickets #NeedSomeLove #Please

Call log and sip trace of the failing call might show the cause of the failure

Just guessing that this is a codec problem. If you have g729 or g722 enabled for either of the trunks, try removing them and allowing only ulaw.

If that’s not it, post a SIP trace, as well as your settings for both of your providers (mask phone numbers, account numbers, passwords and anything else you consider personal).

look at the first post the pastebin link has the log of the call attempt… :wink:
it was too long to paste in the comment

No one is really going to read 6000 lines… Please post a log from one single call.

Also, i see your ring strategy is set to “ringallv2-prim”, try changing it to “ringallv2”

yeah, our pbx is pretty busy during the day, I’ll try to get another one with only one call, my bad.

Is this better?

Have you confirmed that both trunks are using only ulaw?

I’m confused about the providers. 814-5037 was originally assigned to Knology and is now with Troy Cablevision, who I assume is provider A. Your outbound leg to 714-1505 is going via a trunk called ‘troyCable-Out’, but you said that provider B is different. And it appears that you are forcing the outbound caller ID to 814-5001 (also ported to Troy)? Please explain who the players are.

I suspect that your problem is not specific to Follow Me but would affect all trunk-to-trunk connections. For example, if you answer a call on the extension and then transfer it to your mobile, does that fail? Or if (without Follow Me) you simply forward the extension to your mobile, does that fail?

Since the signaling appears to be working correctly, we need (at least) a SIP trace to see why the audio is bad. At the Asterisk command line, do sip set debug on and then try a failing call. Also, post the output of sip show channels , taken while the failing call is connected.

When you post a log, please do it in a way that avoids the terminal escape sequences that make it hard to read. Before posting, check that your paste shows only one line for each line of the log file.

the original provider was WOW used to be Knology WOW bought them out, and yes now is Troy Cable. SIP provider B is Base Communications. I do not know how to transfer a call to my mobile, but I’ll look at figuring it out how to do that today.
see if this is better?

A little progress: Line 24465 shows Asterisk disconnecting the outbound leg for lack of incoming RTP. Do you have the RTP port range of UDP ports forwarded in your router/firewall to the private address of the PBX (I assume that it is With default settings, you should forward UDP ports 10000 through 20000.

Line 10590 shows the outbound call being sent on the trunk. It’s going to ; should it be going to Base Communications instead, or are they just reselling Troy?

If the above is not your issue, we can use tcpdump to see whether RTP is actually coming in (and Asterisk is rejecting it for some reason), or if there is none (presumably due to a problem with the outbound INVITE that I haven’t been able to spot).

1 Like

Thank you so much Stewart1, I’ll pass this along to my ISP TroyCable. maybe they can help me figure out the RTP issue. I understood that when Followme is used, it has to go back out the same trunk it came in on… Troycable has the DID’s that I tested this with in my outbound routes I have Base Communcations as the primary but Troy is the secondary… does that make sense, or am I just smoking something funny? I’ll also check the RTP ports as well on my firewall.

Just to be clear - this is not the case at all. I, for example, have never been able to get FMFM to work using a one-armed route. I have two outbound routes - one for everything except bounce-back routes to cell phones and one for the routes used by the peoples’ cell phones that use my systems.

hmmm, would you mind sharing your outbound routes with me? I do have two outbound routes one for local numbers and one for long distance (basically 10 digits numbers)

There’s really nothing to them. One is an “any/any” outbound route and the other lists all of my client/employee cell phones. The “cell phone” outbound comes first. Nothing tricky or even spectacularly impressive - it’s just like the other one except for all of the destination numbers being set.

In most systems with Asterisk behind a NAT, the router/firewall is configured to forward the RTP port range (UDP ports 10000-20000 by default) to Asterisk. If this forwarding is not in place, simple inbound and outbound calls will still work, because when Asterisk sends media from the extension (or from voicemail, IVR, etc.) to the trunk, the media sent from the trunk is treated as ‘replies’ by the router and gets delivered to Asterisk.

However, in the Follow Me case, you are connecting two trunks together. Since (at the start) no media has been sent to either trunk, media from the trunks does not match any existing ‘connections’ and gets discarded.

As a test, you can set an Announcement for Follow Me, which will answer the call and play some media to the incoming trunk. Then, when the forwarded-to party answers, media from the incoming trunk will be sent to Asterisk and on to the outgoing trunk, whose return media will now also be received.

The issue to which @cynjut refers is different. You are trying to show the original caller’s number on the forwarded-to phone, which requests the outbound trunk provider to send a caller ID that is not yours. Some providers don’t allow this at all. Those that do have different requirements for which header contains the caller ID (From, P-Asserted-Identity or Remote-Party-ID) and the exact format (3345556666, 13345556666 or +13345556666). Once you get the audio flowing properly, if the caller ID is not properly passed, you’ll need to change some settings in the PBX or at the provider.

1 Like

I was told to change the default RTP Port range in asterisk from the 10000-20000 to 16384-32767, but I did do the change at the router as well. I believe @Stewart1 you have found the issue. but since I’m using the same provider’s Trunk I would think it would match. I like your thought process on the test and THAT WORKED! so now my question is what do I need to do to make it work without the announcement? So instead of an announcement, I just changed the ring to play our on hold music. that way asterisk answers the call, and the FM worked! I would still like to know what to do to make it work without it, but for now this is an acceptable work around! Thanks to all who left suggestions, and comments! I honestly don’t know what I would have done if you guys weren’t here!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.