Changed default settings amportal restart Fatal Error (SOLVED)

First off I am running Asterisk Now 1.5
with updated version of asterisk to 1.6
FreePBX is default that came with AsteriskNOW build.

I have uninstalled and re-installed 4 times now.

Cracked it down to when I changed the passwords and user names from the 3 files
amportal.conf
manager.conf
cdr_mysql.conf

to a new user that I have created :

#useradd admin
#passwd admin
#usrmod -a -G admin,adm,root admin

then granted the new user mysql privlidges:

GRANT ALL ON . TO ‘admin’@‘localhost’ IDENTIFIED BY
’password’;

then I reboot and try and login but don’t get that far I get from my browser:
FATAL ERROR
DB Connect Failed.

I have set this up numerous times without a problem.

The only thing that I can think of is its not applying the changes that I have made correctly. Is there a way to see, a script or something that is run after I make changes to passwords and users?

Any help will be greatly appreciated.
Thanks in advance,
Joe

ahh getting somewhere… found it at the top of amportal.conf it states

Run /usr/src/AMP/apply_conf.sh after making changes to this file

well there is no directory named AMP but there is one named freepbx-2.5.1 so instead i ran /usr/src/freepbx-2.5.1/apply_conf.sh and got an output of this…

sed: -e expression #1, char 33: u nknown option to s' sed: -e expression #1, char 29: unknown option tos’
done

Have done my research and have found this link http://www.freepbx.org/forum/freepbx/installation/installation-error-asterisk-1-6-freepbx-2-5

which brings me to this : password must have non-standard characters in it…
well all my passwords have these non-standard characters in it, why is freepbx the only thing that barks at me for it?

Since this seems to be only with freepbx passwords then maybe it should be added to the documentation for the installation procedure… I spent 4 days trying to figure this out. Over and over again uninstall … reinstall.

Well I guess that this make this post short and SOLVED>