Change voice prompts from .gsm to .ulaw?

Our FreePBX system is using the .gsm for voice prompts.

Playing ‘vm-theperson.gsm’ (language ‘en’)
Playing ‘digits/1.gsm’ (language ‘en’)
Playing ‘digits/9.gsm’ (language ‘en’)
Playing ‘digits/9.gsm’ (language ‘en’)
Playing ‘digits/9.gsm’ (language ‘en’)
Playing ‘vm-isunavail.gsm’ (language ‘en’)
Playing ‘vm-intro.gsm’ (language ‘en’)

The .ulaw versions of all those files are in the same directory.

How does one make FreePBX use the .ulaw files instead?

The codec priority is already set to ulaw first.

Nobody knows?

It depends on the codecs used in your sip configuration.
Use Asterisk SIP Settings module to change it.
As you have not provided the version of FreePBX, I don’t know if it is available to your version. Asterisk SIP Settings was released with FreePBX 2.6

I have FreePBX 2.9.0.7

I had both GSM and ULAW selected.

If both are selected, GSM prevails for the voice prompts? (GSM prompts were used even in ULAW calls).

If I unselect GSM, and a GSM call comes in to an extension or trunk, will it be transcoded to match the ULAW voice prompts or dropped because I unchecked it in the Asterisk SIP module?

Thanks.

Move ulaw to the top before gsm, that should fix it.
But, if a call comes in with request for gsm, it will go gsm.

Just unselect gsm from SIP Settings, then Asterisk will transcode to ulaw, but it will add some latency.

More reading: http://www.voip-info.org/wiki/view/Asterisk+codecs