Change repo server in advanced settings

I noticed that I cannot change the repo server field in AdvancedSettings.
Also when I override settings.
I want to play with my own repo server for updates.
Thanx in advance

Because it can cause and break lots of things so we do not allow it to be changed. Sorry.

Thanx for your answer Tony.

Is there a special reason for readonly on this setting?

That is one of the many settings that you can not change. Its just a readonly setting and can not be overridden.

Ok that is clear,

But sometimes the pbx gets messed up by new module updates wich gets fixed after a update afterwards.

Is it alternatively possible to shut down module update notices in the Freepbx Status overview?

Ik disabled automatic update warnings but this is always still visible in in FreePBX status overview.