Change of ip

I’ve got a stable setup running FreePBX / Asterisk (Ver. 11.20.0) on raspberry pi, I’ve tried searching for answer but am more confused if anything.

I need to change ip address of this setup due to change of location, where I don’t have control over bthub gateway (I can change gateway ip but it may be reset by others using it).
I currently have a static ip of 192.168.0.XXX but need to change to 192.168.1.XXX. please can someone tell me how it would be possible to make this change? last time I tried to change ip I used nano /etc/network/interfaces (this is how I configured static ip when new) but i lost all communication with it, which although is not a complex or big system was bit of a disaster for me.
I’ve got backups of everything this time but it would be a lot better for me if changes could be made to existing setup without having to start over.

thanks in advance.

If you have System Admin, you could change the IP within System Admin / Network Settings. I am not sure if this is part of the System Admin Pro or not. If you do not see it, buy a license for it, makes it so much easier to do certain things.

You will need to be in “the same network” as your box or have a route to it, if you “lose all communication”, you might want to previously add another ip/network rather than replace the apparently working one while it works. using “ip” the recommended modern network tool:-

ip address add dev eth0 (where xxx is an unused address and between 1 and 254, you don’t need to obfuscate private addresses :slight_smile: )

would do that until you sort out your own hosts’s ip address/network, both should work depending on the network your access machine is in, if there is a route between your control host and the PBX, it gets more complicated to traverse that route, when the new network/routing works then do the /etc/network/interfaces thing and /etc/init.d/networking restart , don’t waste your time or money with any commercial solutions as otherwise suggested, they won’t ever work on your hardware.

thanks deanot26508 but it does not have system admin.

thanks also diicko, i’m not sure how to use that information - should I enter ip details in command line?

Yes perhaps read

Look at eth0:0 for another ip

hi dicko, I carried instructions in that post adapting to ip of my new environment, took my raspberry pi to new office, plugged in and exactly the same thing happened; there was no communication at all. the only way I could communicate was to plug hdmi and usb keyboard into pi and log in that way.
I also carried out the advice of the link poster and did a backup of interfaces file, I renamed my backup, took to original location. connected and all functioning ok again.
I ran ifconfig and this is the result:
lo Link encap:LocalLoopback
inet addr: Mask
inet6 addr: :: 1/128 Scope:Host
RX Packets:180 errors:0 dropped:0 overruns:0 frame:0
TX Packets:180 errors:0 dropped:0 overruns:0 frame:0
collisions:0 txqueuelen:0
RX bytes:12236 (12.0 kib) TX bytes:12236 (12.0 kib)

I know I don’t know what i’m doing but what’s is I don’t know what i’m doing wrong.

your eth0 interface is not up. see what ifup eth0 returns, Check your work.When it is up then tcpdump should give you a clue as to the ip addresses otherwise present on the network interface.