Change in 2.4 handset must be down to intercom or dial voicemail

Why was it changed in the new 2.4 version of FreePBX that the handset must be down when initiating the call to voicemail or intercom? When I have the handset up and dial I just get a busy tone.

I’d take a look at your setup for something else that has changed in your setup. Most likely in your phone configuration? It works just like it always has on my Aastra, soft phone and Cisco phone setups. The phone controls handset / headset /
speaker phone control.

Running the latest FreePBX 2.4 with all updates.

I thought that at first, but I don’t see anywhere in the FreePBX menus to change that and I’m using the same firmware as before; which is Polycom 2.1.2 on 501 and 301 phones. I didn’t move to 2.2.0 because the 301’s don’t work on that and I noticed that FreePBX made changes to the intercom feature so that Polycom wasn’t the only supported phones.

what you describe or at least the way you describe it shouldn’t have anything to do with FreePBX. As far as Polycom phones and intercom/paging - the current default settings should continue to work with them as they always have in recent releases. If you have done anything ‘non-standard’ to your phones, the new Paging and Intercom module allows for extensive database driven customization on a per “useragent” basis, per FreePBX “device” basis or to the actual defaults that are applied. Most of these changes require an understanding of how the module uses the database (both SQL and Astdb depending on what you are doing). You can get this by reviewing the code.

However - as mentioned, Polycoms continue to work as they always have, not change there.

Do you know where these default settings are? Is it possible that the firmware I’m using doesn’t work with FreePBX 2.4?

as was mentioned, you are probably looking in the wrong place. If you had a working system with 2.3 and Polycom phones, you then upgraded to 2.4 and did nothing else, then Intercom and Paging should continue to work as before. Further more, if the issue is around dialing with the handset down vs. off hook, then it really is a Phone configuration issue.

I was using version 2.3 with trixbox 2.2.12 and then I did a clean install to trixbox 2.6.0 which came with FreePBX 2.4. The only thing I added extra was polycom firmware. Is it possible that I should be asking trixbox this question?

trixbox 2.6 is a issue. They have many, many issues currently with it installing and working with build

Then I shall take this issue up with them. Thanks for everyones help. Now I know what has changed and what hasn’t in FreePBX in case trixbox asks.

If you are using a Polycom 320/330, the phone dialplan is ignored if you dial with the handset on hook. Look in the phone1.conf file in /tftpboot directory. You can modify the phone dialplan for all polycom phones in that file.