Change Hostname from freepbx.sangoma.local

Have 15.0.7

Hostname appears as freepbx.sangoma.local

I can make changes by Admin>System Admin>Hostname. but when I click to “Update Hostname” it immediately reverts to the previous: freepbx.sangoma.local

It will not change. I’ve tried a reboot or two, as well as looking under /etc/hostname…no luck

I’m assuming this has something to do with my activating something with Sangoma(?) (which was done solely to pay for a pro fax module).
HOw do I fix this and get the hostname back to a FQDN?
It appears that perhaps this is the cause of why voicemails sent to gmail accounts are never arriving, while emails sent to numerous other email addresses are arriving immediately?

i’m not particularly convinced this is THE cause… but email sent to other domains show an alert “status: OK” and “accepted for delivery”, while the gmail simply shows “Status: OK”, but doesn’t show the last part…

Please post

hostnamectl

you can change that with

hostnamectl set-hostname a.b.c

If you did that , does it work?

many thanks - that fixed it entirely!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.