Chan_SCCP-4.2.1_STABLE fails to install

hiyas guys/gals i have a small problem .im new linux so please are with me, my friend picked up some old cisco 7960g ip phones and wants to hook them up but without buying a full cisco rig we thought it couldnt be done till i googled asterisk can on freepbx. so here i go i installed vmware on my lappy to see if i can do this. i installed the freepbx on it and then read up on the net i needed a special driver so i got that Chan_SCCP-4.2.1_STABLE_r6370 so i worked out how to get that on the machine. then learnt how to extract it… pat on the back for me… now when i went into the folder and ran ./configure it comes up with this error and i dont know how to fix it…

Checking Configure Options:
checking pkg-config asterisk… not found
checking Search Path: /usr /usr/local /opt… not-found
not-found
not-found
configure: Please install either the asterisk-devel package.
configure: Or run ./configure --with-asterisk=PATH with PATH pointing to the directory where you installed asterisk
configure: error: Cannot find pbx libraries - these are required.
[[email protected] Chan_SCCP-4.2.1_STABLE_r6370]#

now i first did it in the home dir nothing so then i went to etc/asterisk/ and popped the folder in there and ran .configure again and nothing i get same error… can anyone tell me where im going wrong because asterisk is installed but the os cant find it im very confused.

thank u inadvance for anyone taking the time to answer

now i just tried doing ./configure etc/asterisk/ and it spewed this out at me

checking build system type… Invalid configuration /etc/asterisk/': machine/etc/asterisk/’ not recognized
configure: error: /bin/sh autoconf/config.sub /etc/asterisk/ failed
[[email protected] Chan_SCCP-4.2.1_STABLE_r6370]#

now im dazzed and confused please help

james

You must install asterisk sources. In order to let us help you, you should at least tell us which version of freepbx you are using.

I hate to bring up an old thread, but I am having the same issue. I am running FreePBX 14.0.13.6, with Asterisk 16.3.0.

How can I get around this?
Thank!
Mike

As I will search for this in the future when I run in to this, I needed to run ‘yum install asterisk-devel’.
Problem, solved.

There was a typo with the “predefined” include file. I (and a couple other folks) had to edit the source and comment out the include file which seems to be double including itself with safety code. I need to let Deidrich know there’s a problem.

Can you share what you had to edit? I am getting an error loading chan_sccp.so. Thanks.

I am trying this on Asterisk 13.27.1. It loaded fine in my test VM today that is running 16.3.0.

[2019-10-24 20:01:32] WARNING[4979]: loader.c:586 load_dlopen: Error loading module ‘chan_sccp.so’: /usr/lib64/asterisk/modules/chan_sccp.so: undefined symbol: stasis_subscription_set_filter

That’s a version mismatch. Your asterisk-devel files are different than your kernel. If you’re not getting a bunch of “already defined” errors, the problem has probably been fixed.

Interesting, that is on a Sangoma box that I just got,

Package asterisk13-devel-13.27.1-1.sng7.x86_64 already installed and latest version

What am I missing? I built chan_sccp on this machine. So I am not sure what is going on.

Check your kernel version and see what that says. It should closely match your asterisk-devel version.

After that, it’s going to be time to hit the chan-sccp-b forum and see what Deidrich has to say. It should build correctly with that old a version of Asterisk, but it’s possible he missed something and it needs a newer Asterisk version.

It appears to be 3.10.0-862.2.3.el7.x86_64.

Linux version 3.10.0-862.2.3.el7.x86_64 ([email protected]) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-28) (GCC) ) #1 SMP Wed May 9 18:05:47 UTC 2018

Thank you Dave! That did the trick

Linux 4.4.197-1.el7.elrepo.x86_64 #1 SMP Thu Oct 17 18:03:47 EDT 2019 x86_64 x86_64 x86_64 GNU/Linux