Certificates can't be deleted from Certificate Manager?

Hey Everyone,

I’m in a bit of a dilemma which was likely caused by my hasty actions when I deleted some certificate files in /etc/asterisk/keys.

Using FreePBX Distro
PBX Firmware: 10.13.66-12
Current Asterisk Version: 13.9.1
Certificate Manager 13.0.25

The certificates still show up in the Certificate Manager but when I attempt to remove a certificate by clicking on the trash can in the Certificate Manager I’m presented with some kind of colourful interactive debugging screen saying

Whoops \ Exception \ ErrorException (E_WARNING)
Invalid argument supplied for foreach()

among other things listed there

I’ve tried uninstalling the certificate manager from the module admin console but get

Error(s) uninstalling certman:
Failed to run un-installation scripts

Removing the Certificate Manager altogether and re-downloading it doesn’t change anything either.

I have tried going in ssh as root and using the command

certutil -L

to list all certs but get an error saying

The certificate/key database is in an old, unsupported format.

Not sure where to go from here. I’m not an experienced Linux user so any help will be appreciated

Login to ssh:

fwconsole ma upgrade certman --edge

now go and remove your invalid certificates

That was my ticket! Thanks!

1 Like