Certificate Manager Problems

I tried to create a certificate, but got the message that there was no CA. I tried to create a CA but got the message there was already a CA. So I created a new CA anyway, but then when I tried to create the certificate I got an error about the CA. So I went back and this time deleted the CA and then tried to create a CA but got a timeout message OpenSSL took too long to run the command "/usr/bin/openssl genrsa -des3 -out /etc/asterisk/keys/ca.key -passout stdin 4096".

I dropped to the console and ran /usr/bin/openssl genrsa -des3 -out /etc/asterisk/keys/ca.key -passout stdin 4096 manually and was able to create the CA, however, it can take a very long and unpredictable amount of time because of how the key is generated and I’m guessing the timeout in PHP isn’t taking this into sufficient account (so you probably just need to keep trying until it eventually succeeds)

So, I got the CA create to succeed eventually and then was able to generate a certificate.

But I have found “Certificate Manager” to be flaky at best so far.

Distro 6.12.65-24

I have taken these issues into account with certman 12.0.4