Centos 5.2, cannot disable selinux

We have confirmed it with our datacenter we cannot disable selinux. We did try but our server would not boot up.

Has anyone been successful installing freepbx 2.5.0 with asterisk 1.4.22 and not disabling selinux. All the other steps for “installing centos 5.1” instructions were very straight forward.

Please do NOT double post.

You should be able to edit /etc/sysconfig/selinux and set SELINUX=disabled.

But if by ‘cannot’ you mean ‘not allowed’, you are in for some work. Unless you can find a readymade SELinux policy for CentOS, you’ll need to create your own. There are plenty of tutorials out there on that (http://wiki.centos.org/HowTos/SELinux, for one), but you will need access to a box with asterisk installed and selinux set to ‘permissive’ before you can use audit2allow. I gave up around this point and disabled it :confused:

After that you’ll probably find that the policy for apache freaks because it’s running as asterisk and modifies files in /etc.

Post back if you get it working. And good luck!

Hi gurus!
CentOS 5.2
Eventhough i have disabled Selinux with the /etc/sysconfig/selinux to:
SELINUX=disabled
SELINUXTYPE=targeted
SETLOCALDEFS=0
and reboot the machine I get this:

[[email protected] ~]# sestatus
SELinux status: enabled
SELinuxfs mount: /selinux
Current mode: permissive
Mode from config file: disabled
Policy version: 21
Policy from config file: targeted

Is there a way to show the SELinux status as disabled ?>