Centos 5.2, cannot disable selinux

We have confirmed it with our datacenter we cannot disable selinux. We did try but our server would not boot up.

Has anyone been successful installing freepbx 2.5.0 with asterisk 1.4.22 and not disabling selinux. All the other steps for “installing centos 5.1” instructions were very straight forward.

SELinux is a security measure that has many ramifications. Whoever is building your boxes does not know what they are doing (or is just refusing to do it) as it is an additional security layer that is added.

More info can be found here: http://www.redhat.com/docs/manuals/enterprise/RHEL-4-Manual/selinux-guide/selg-preface-0011.html

In freepbx “install process for centos 5.1” it asks to disable selinux. It sounds like it is good to have selinux enable. How do others workaround this.

instructions for installing freepbx on centox 5.1 http://www.freepbx.org/support/documentation/installation/install-process-for-centos-5-1

The install and operation will not work if it is enabled, that is why you are instructed to disable it.

google is your friend… asterisk selinux

are two places to start.