CDR Reports not working after update

Output from:

 asterisk -x "cdr show status"

[email protected]_alt2:/etc $ asterisk -x “cdr show status”

Call Detail Record (CDR) settings

Logging: Enabled
Mode: Simple
Log unanswered calls: No
Log congestion: No

Registered Backends

cdr-custom
csv
res_config_sqlite
Adaptive ODBC

How about:

cat /etc/asterisk/cdr_adaptive_odbc.conf

[email protected]_alt2:/etc $ cat /etc/asterisk/cdr_adaptive_odbc.conf
[asteriskcdrdb]
connection=asteriskcdrdb
loguniqueid=yes
table=cdr
alias start => calldate

I am running out of things to check …

 asterisk -x "odbc show asteriskcdrdb"

ODBC DSN Settings

Name: asteriskcdrdb
DSN: MySQL-asteriskcdrdb
Last connection attempt: 2017-01-24 17:32:41

So these ones are ok"

Registered Backends

cdr-custom
csv

I’m not sure if this helps or not, but my UCP also doesn’t show any calls since the update.

I fear we’ve arrived at another dead end. Perhaps someone with more CDR ODBC experience can see the missing piece of the puzzle here.

Anytime I click “Save Changes” I see this when in the CLI, maybe it’ll shed some light…
Seems like it can’t connect.

I think this is the same issue I’m having:

I checked my odbc.ini file & I don’t have a username or password.
I found my user name & passward in: /etc/asterisk/res_odbc_additional.conf
But when I tried:

isql -v MySQL-asteriskcdrdb asteriskuser PASSWORD

I got the same errors:

[IM002][unixODBC][Driver Manager]Data source name not found, and no default driver specified
[ISQL]ERROR: Could not SQLConnect

OK with the help of my coworker (Linux & MySQL export) & this link:
https://www.minestron.it/asterisk/cdr-de-asterisk-usando-odbc-no-mas-mysql
we finally got the CDRs to log again!

I had to edit "/etc/odbc.ini"
The first line is the data source, it had:

[asterisk-cel] (or something like that, I think cel only works with Asterisk 13)

I changed it to:

[MySQL-asteriskcdrdb]

It has to match the dsn value from this file “/etc/asterisk/res_odbc_additional.conf”

[asteriskcdrdb]
enabled => yes
dsn => MySQL-asteriskcdrdb

1 Like

This is incorrect.

So why then did the data source change to [asterisk-cel], if I’m still running Asterisk 11?

That may be correct but what I was referencing was “I think cel only works with Asterisk 13” that is not true.

Oh, this is what I see when I go to the CEL module.


Should I have said 12?
Or are you saying it works with 11 too?

No that message is correct for the CEL GUI PART OF THE MODULE. But CEL itself has been supported since 2.10 or so. You can see this when you click on calls in CDR as it shows CEL data from there and requires the CEL module it do this. The only thing you can’t do with Asterisk 11 is use the GUI portion of the CEL module.

Thanks very much!

Hello all. I had this same issue but was able to resolve by sshing into the box and running:

  su -c 'yum update'
  yum list asterisk11*
  yum check-update astersik11*
  yum upgrade asterisk11*

After reboot, I was able to receive CDR reports again. Sidenote: the database itself had been damaged and was repaired This is after running mysql checks and repairs, of course.

For mySQL database repair (after backup):

  mysqlcheck -r --all-databases

Hope that helps someone out there in the future.

Help … with me it is not I have made the update to 14 …

greeting
Thomas (Germany)

Hi!

On a FreePBX distro with tge distro upgrade “script” or something else?

If you used the distro upgrade “script” then please check for this:

and this

Good luck and have a nice day!

If it is not that then please give more information about your setup…

Nick