CDR question

I have a custom context that sends a page during emergency alerts, such as tornado warnings.
I’m trying to clean up the CEL so that it shows the correct destination, which should be “Alert”.
Currently, the system works, but shows the destination as “s”.
I’ve tried a number of variations on the CDR command, but nothing seems to change it from “s”.

Here is my current dialplan.
[custom-ebs-alert]
exten => s,1,Noop(EBS Alert)
same => n,Wait(8)
same => n,Answer()
same => n(start),Macro(user-callerid)
same => n,Set(CDR(outbound_cnam)=Alert)
same => n,Gosub(sub-record-check,s,1(EBS,981,force))
same => n,Set(DB(alerts/time)=${EPOCH})
same => n,Set(DB(alerts/file)=${ASTSPOOLDIR}/monitor/${YEAR}/${MONTH}/${DAY}/${CALLFILENAME})
same => n,Page(LOCAL/[email protected])

Hi,

What version of asterisk is your system running?

Asterisk is 16.2 something.

Can you post a screenshot of what everything looks like in the CEL

Here is the CEL. YOu see on line 2 I got the recording. But the “dialed destination” is listed as “s”. I would like to make that say “Alert”.

That looks a little different than my CEL reports we may have different versions. That shouldn’t be a problem. I wanted a screenshot because that included things like the event type and channel. Either way Ill just ask you some questions myself.

How does your system currently work. Does a user dial a certain custom destination extension to send out a specific page?

If so change this

[custom-ebs-alert]
exten => ALERT,1,Noop(EBS Alert)
same => n,Wait(8)
same => n,Answer()
same => n(start),Macro(user-callerid)
same => n,Set(CDR(outbound_cnam)=Alert)
same => n,Gosub(sub-record-check,s,1(EBS,981,force))
same => n,Set(DB(alerts/time)=${EPOCH})
same => n,Set(DB(alerts/file)=${ASTSPOOLDIR}/monitor/${YEAR}/${MONTH}/${DAY}/${CALLFILENAME})
same => n,Page(LOCAL/[email protected])

and then in the custom destination change it to

custom-ebs-alert,ALERT,1

But if this doesn’t fit your situation what we need to change specifically is the CEL exten event and I can go more in depth if needed

That sounds like a good plan, I just have one question.
The radio is connected to a DAHDI port, and uses the “immediate” to page as soon as the radio opens the port.
How would I add the “alert” priority to the config so it specifically goes there?

I tried to change the context to “custom-ebs-alert,Alert” but then it tries to dial custom-ebs-alert,Alert,s,1.
This fails with an invalid number, obviously. So I don’t know what the correct syntax is and I’ve been reading the documentation, but I can’t find this anywhere.

Ok with DAHDI that changes some things. Under the extension settings turn Immediate to No
and change the context to “from-analog” instead of “custom-ebs-alert”. Then go to Connectivity > DAHDI Channel DIDs and add one. Your channel is 2, the description can be Alert, and then make the DID a 4 digit number that you remember.

Once thats set go to Admin > Custom Destination and create a custom destination that points to

custom-ebs-alert,ALERT,1

Just call it Alert for the description

Then we can create an Inbound Route that will route that DID (the 4 digit number) from the DAHDI to that custom destination you created (Alert).

This should allow everything to get routed correctly and define the extension ALERT as the destination in the CEL

This is great stuff and I was sure it would work, to my surprise it’s still saying “s”, but I verified it is going through your dialplan.
Also, I had to turn on immediate or nothing would happen. Please explain why you wanted to turn it off?
And thanks for your time, by the way.

From my understanding I didn’t think you wanted immediate set to yes. Because we mapped out a destination based on the DADHI DID that should have fixed the issue. Can someone else chime in if i’m missing something or wrong?

With immediate set to yes it just says go to the s extension and priority 1 the defined context. So that may be why you’re still seeing s as the destination.

I’ll have to do some more research…

but without immediate, it won’t “autodial”, unless I misunderstand.

no, it’s definately going to the new custom destination as you instructed.

in fact, s no longer exists. I replaced it with custom-ebs-alert,Alert.
That part works. But CEL still shows s as destination.
I think it is coming from the PAGE app.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.