CDR not showing up

Hi All,
I’ve searched the forums and found several reports of similar issues, but haven’t found a fix that works yet.
I’m running AsteriskNow 1.71, with freepbx updated to, asterisk

My CDR reports are empty, and I can’t figure out why, it says “no data”. I’ve installed asterisk-addons via yum. I checked the permissions on the /var/lib/php/session folder and they are set as asterisk owning it.
I checked mysql and the freepbx user does have all permissions on the asteriskcdrdb database. Note I have changed the default password of the freepbx user.
I updated /etc/asterisk/cdr_mysql.conf to have the new password.
I also tried changing the username and password there to root as well, it didn’t have any effect.

So, I logged into mysql as freepbx, and verified there were no rows in the cdr table under asteriskcdrdb. I manually inserted a row into the cdr table under asteriskcdrdb, and voila! I see that record now in my CDR report. However making some test calls after that, they don’t show up.

So this tells me permissions on the file system seem OK, as once the record is in mysql everything else is working. So it appears to be an issue either with credentials to login to mysql somewhere, or that process is not even getting initiated.

Anyone have any suggestions?
Is there a way I can see logs from mysql to see if there is a login attempt coming after a call?

What do you see when you run in Asterisk CLI
module show like

Should show 1 modules loaded

Thanks sanjayws, that got me on the right track.
Noticed it said 0 modules, so edited modules.conf to add that in, did amportal restart.

Still not going, but then I found these errors:
[Apr 13 10:18:48] WARNING[20852] loader.c: Module ‘’ was not compiled with the same compile-time options as this version of Asterisk.
[Apr 13 10:18:48] WARNING[20852] loader.c: Module ‘’ will not be initialized as it may cause instability.
[Apr 13 10:18:48] WARNING[20852] loader.c: Module ‘’ could not be loaded.

So, I first did:
yum update asterisk16

Then did:
yum reinstall asterisk16-addons
yum reinstall asterisk16-addons-mysql
yum reinstall asterisk16-addons-core

amportal restart

now CDR’s are working!

Thanks for the help.