CDR Call Record Icon

Hi,

We are using FreePBX 2.11 and we are having some issues with the Reports / CDR Reports option.

The icon you get to play the recording is not showing…

We don’t store the recordings on the local disk, but on a NAS and we’ve set the Override Call Recording Location to /var/callmon

All the recordings are going in there fine, but we have to enable SMB and play them over the network as they don’t show in the CDR logs any more.

Our UK PBX works fine where we store the recordings in the default location.

Many thanks,
shaun Okeefe

I would suggest that a SMB share is the worst place to write your recordings to as the permissions are nebulous. Perhaps use NFS or if that is not an option, “mount --bind” your share over the original /var/spool/asterisk/monitor directory, maintaining the permissions needed (asterisk must be able to read and write to that share)

Hi There,

OK so I did a mount --bind /var/callmon /var/spool/asterisk/monitor

changed the path in the advanced options to default so now I have this

/var/spool/asterisk/monitor
[[email protected] monitor]# ls
2013 lost+found
[[email protected] monitor]#

So the recordings are going to the default place…
[[email protected] monitor]# ls -lt
total 20
drwxrwxr-x 8 asterisk asterisk 4096 Oct 1 01:04 2013
drwxrwxrwx 2 asterisk asterisk 16384 Sep 12 2011 lost+found
[[email protected] monitor]#

Still doesnt show in the GUI though :confused:

Cheers,
Shaun