Cant use queue command, but if i use goto it works

I am trying to program a ivr to call a freepbx queue,

when i use


the queue music starts ok, but no phone is ringing.

If i try like this:


It works perfect, but the fact is that i really need the command queue working because i need to do some specific option of this command.

Somebody knows how can i solve this? It is a bug?

Another strange thing is that the queue command cause other issues in the freepbx, it goes slowly, but there is nothing happening in the logs.

I noticed that the processor is going to 100% when using queue function instead of goto.

You need to use goto. Meaning you have to use the freepbx context. There is no way around this.

The thing is that i need to continue the call when the answer clerk hangup (a post IVR evaluation), with queue function there is a continue option that makes the call continue, but with goto i cant do that.

There is some way to continue executing the ivr when the queue stops?

VQ Plus (not free) has this feature:

Thank you friend.

There is a way to program my own queue that works with queue command?

What is this callback_id on the table queues_config? Maybe this can help me to send the queue to another extension when the answer clerk hangup?

That is not what the callback is for

There is some way to made freepbx to act like asterisk when using the queue command? Editing some part of the code, or something? Removing some functionality? I hear that this command are working in old versions, maybe getting a old version of a specific agi script?

I found a easy solution simple run this commands:

cp /etc/asterisk/queues_additional.conf /etc/asterisk/queues_additional.conf-freepb
sed 's/member=Local\/\([0-9a-zA-Z_]*\).*,\(.*\)/member=SIP\/\1,\2/' </etc/asterisk/queues_additional.conf-freepbx >/etc/asterisk/queues_additional.conf
asterisk -rx "reload"

To make it persistent just add a script in /etc/amportal POST_RELOAD script section that calls that commands.