Can't upgrade / enable framework module

I have updated all of my modules. After that, the framework module has not been updated and has been disabled. I have tried to enable it or update it, but when I do this the gui shows no progress and after a while, it shows an out of time error.
I also can’t uninstall and reinstall the module, because other modules need it and they can’t be disabled.
When I try to upgrade the module using the console, (it takes forever and) I also get an error:

fwconsole ma upgrade framework
No repos specified, using: [standard,extended,unsupported] from last GUI settings
Starting framework download..
Processing framework
Verifying local module download...Verified
Module framework successfully downloaded
PHP Fatal error:  Maximum execution time of 750 seconds exceeded in /var/www/html/admin/libraries/BMO/GPG.class.php on line 190
Whoops\Exception\ErrorException: Maximum execution time of 750 seconds exceeded in file /var/www/html/admin/libraries/BMO/GPG.class.php on line 190
Stack trace:
1. () /var/www/html/admin/libraries/BMO/GPG.class.php:190
Updating Hooks...Done

maybe try this :

amportal chown
amportal a ma refreshsignatures
amportal a reload

and then try to upgrade

No, unfortunately the same error.

see this:

Ok, but how can I fix this?

he said in the thred he ran this :

fwconsole ma install certman


Yea, I’ve tried this. But it can’t find the module certman:

fwconsole ma install certman
Unable to install module certman:
 - Cannot find module
Updating Hooks...Done
fwconsole ma downloadinstall certman

I installed that, but it did nod help.
Also I can’t “Apply Config”.

fwconsole reload
Reloading FreePBX