Cant transfer to voicemail

Anyone have any ideas?

I see a bunch of similar threads over the years and I don’t see much of a resolution on any of them. I just had this come up. Some things suggested in the other threads were to make sure that * is the voicemail prefix and to try ## instead of the transfer button on the phone. I checked/tried those.

Here is what I see in the CDR where I call in and they try to transfer me to voicemail for x106.

I checked

  • that x106 has voicemail enabled,
  • that the template that the phone is using has a dial plan that will accept *106,
  • that the “direct dial prefix” for voicemail is set to * and enabled,
  • that the version of Asterisk they’re running will support this on a different PBX (13.22.0),
  • and that it works with Yealinks specifically. The person that reported the issue is using a t42s and we tried with another t42s on a different system.

I see in the full asterisk log where she tries to transfer

pbx.c: Executing [*[email protected]:1] Answer("SIP/VI-Inbound_64.136.173.31-00000423", "") in new stack

then a few lines further down i see the where it processes the call as a “bad-number” and then starts the hangup procedure

pbx_builtins.c: Goto (bad-number,s,1)
pbx.c: Executing [[email protected]:1] Goto(“SIP/VI-Inbound_64.136.173.31-00000423”, “11,1”) in new stack
pbx_builtins.c: Goto (bad-number,11,1)
pbx.c: Executing [[email protected]:1] ResetCDR(“SIP/VI-Inbound_64.136.173.31-00000423”, “”) in new stack
pbx.c: Executing [[email protected]:2] NoCDR(“SIP/VI-Inbound_64.136.173.31-00000423”, “”) in new stack
pbx.c: Executing [[email protected]:3] Progress(“SIP/VI-Inbound_64.136.173.31-00000423”, “”) in new stack
pbx.c: Executing [[email protected]:4] Wait(“SIP/VI-Inbound_64.136.173.31-00000423”, “1”) in new stack
pbx.c: Executing [[email protected]:5] Playback(“SIP/VI-Inbound_64.136.173.31-00000423”, “silence/1&cannot-complete-as-dialed&check-number-dial-again,noanswer”) in new stack
file.c: <SIP/VI-Inbound_64.136.173.31-00000423> Playing ‘silence/1.ulaw’ (language ‘en’)
file.c: <SIP/VI-Inbound_64.136.173.31-00000423> Playing ‘cannot-complete-as-dialed.ulaw’ (language ‘en’)
file.c: <SIP/VI-Inbound_64.136.173.31-00000423> Playing ‘check-number-dial-again.ulaw’ (language ‘en’)
pbx.c: Executing [[email protected]:6] Wait(“SIP/VI-Inbound_64.136.173.31-00000423”, “1”) in new stack
pbx.c: Executing [[email protected]:7] Congestion(“SIP/VI-Inbound_64.136.173.31-00000423”, “20”) in new stack
pbx.c: Spawn extension (bad-number, 11, 7) exited non-zero on ‘SIP/VI-Inbound_64.136.173.31-00000423’
app_stack.c: SIP/VI-Inbound_64.136.173.31-00000423 Internal Gosub(crm-hangup,s,1) start

Obligatory:
Current Asterisk Version: 13.22.0
FreePBX 14.0.7.7
PBX Firmware:12.7.5-1902-3.sng7

So the issue is only wuth T42S model?

Can you post the full call trace?

I meant that this was reported by someone using a t42s so we tried with another t42s on a different pbx and it worked there.

Look through the feature codes page, there might be a conflict.

If you find none. Please post the full call trace.

Apparently when we tested on other phone servers we were dialing 4-digit extension numbers. This only seems to be an issue with 3-digit extension numbers, and more specifically 3-digit extensions in the 1XX range. I can duplicate the issue when I make x106 on a different PBX but it works fine for x206.

I don’t see anything obvious in the feature codes, the dial plan, or the advanced settings.

Can you post the full call trace?

Did you change the Speed Dial Feature Code from *10? Because if you didn’t *106 will be treated as *10 (speed dial) to extension 6. So you either need to change your speed dial feature code or your direct dial voicemail feature code.

Derp. Not sure how I missed that one. Thanks, that fixed it.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.