Can't set "skip Busy Agents" queue option from Freepbx GUI


When i try to set the value for the queue option “Skip Busy Agents” in Freepbx GUI it is not being written into the backend file queues_additional.conf. As a result sometimes agents in queue gets calls when they are already busy with another call. So i set “ringinuse=no” option manually from backend. Is it bug ? Is there any fix for this?. I am providing the details of version of asterisk and freepbx.

Asterisk : Asterisk

FreePBX version :
queue Module version :

Please update your queue module, you are running an invalid configuration, if you are running FreePBX the queue module should be

Go to Module Admin, click on Check for updates online

Update all module to the latest version.

Thanks Mickecarlsson for your advice. Is there going to be any problem with the updation. Will there be any change for the current queue settings ?

skip busy agents has multiple options and not all of them set ringinuse=no. You should review the tooltip to see the different options.

It’s primary mode does not interact with the queues app at all. It simply informs dialparties.agi (in the case of version 2.7) to to treat the line as if there was no call waiting. So the queue app will try to make the call, but the dial script will see that the line is occupied and thus not interrupt the agent.

The use of ringinuse=no (which some of the options trigger) has a potentially negative side effect as documented in the tooltip.