Can't Restore from FTP Backup

FreePBX 13.0.120
PBX Firmware: 10.13.66-11

I added an FTP server in Active mode. Ran a Full Backup to the FTP server, and everything worked.
Try to restore the backup I just made. Clicked Restore / Browse, select FTP server. It shows the backup file in the list. Click it, and details appear on the right. Click “GO!” and get this error: “Invalid backup for or undefined error”

Go back to Restore, but this time instead of GO, click Download. Get a crash screen displaying this:
> Whoops \ Exception \ ErrorException (E_WARNING)
> file_exists() expects parameter 1 to be string, array given
> /var/www/html/admin/libraries/utility.functions.php
> * @pram string, optional - content mime type
> * @pram bool, optional - true will force the file to be download.
> * False allows the browser to attempt to display the file
> * Correct mime type ($type) snesesary for proper broswer interpretation!
> *
> */
> function download_file($file, $name = ‘’, $type = ‘’, $force_download = false) {
> if (file_exists($file)) {
> //set the filename to the current filename if no name is specified
> $name = $name ? $name : basename($file);

I started over and tried all the same steps, using Local Storage instead of FTP, and the whole process completed successfully. Could you help me troubleshoot the problem?