Can't reload "freepbx can't connect to the asterisk manager interface"

I use PIAF 1.4. and Freepbx 2.7. A few days ago without doing anything in particular but upgrading modules I faced error messages, and the orange bar still there. I can’t reload and several modules including extensions, day/night and most impportant backup/restore are in gray and can’t be accessed.

I tried to upgrade to 2.8 but again, while the upgrade module was installed can’t upgrade the rest of the modules and in fact are unable to use the GUI. The server is working but since it is a production one I wonder how can I fix the problem without the need to reinstall the whole server from start?

Is there a way to restore past configuration via the CLI and not the GUI? I have a backup file from a month ago…

Did you check if your local host address is setup right ?

Both internal and external addresses are the same. Nothing has changed

If your loopback is missing or wrong the Asterisk Manager can’t connect.

This happened to me before for some reason and I had the same behavior.

A lot of grayed out buttons etc.

Have you used the webmin interface or the CLI ?

I don’t use webmin for that server nor did I ever touched such definitions. Where should I look for that?


login with you root and password

look in


  • Network Configuration

Look around and see if your localhost is set properly to loopback at

Not sure if you are familiar or not with these setting (no insult :slight_smile: )

However the server is remote so only 2morrow will be able to point port 10000 to access it.

Will keep you posted. Thx for now.

PIAF puts webmin on port 9001 by default

Host and loopback are set to

However there are some weired add-ons

eth0 Ethernet Up

Ethernet fe80::218:f3ff:fea9:69bc 64 Up

lo Loopback Up

Loopback ::1 128 Up

Next to the legitimate interfaces there is a square so I can delete but no such aquares next to the add-ons so I can’t delete it. Any advise?

At etc/hosts localhost was orphan…so I added and it solved the problem.
Thx a lot mate.

Well my friend,

I have searched many sites and nobody had an answer for me either.

So I thought that this posting should help a lot of people that seem to have the same problem.

Even the people I work with didn’t knew it.

Though it seems so easy to fix.

The basic instructions I got before was to just reinstall the system.

Glad to be off help.