Can't register extentsion with sip soft phone

i am using freepbx 2.8 beta,
i cannot create an extension with an x-lite device.
turned off my firewall.
i set the extension to 996
i set the display name to yourname freepbx.
i set the secret to abram76
my pbx ip is

then i went to my exlite and did these configurations

i get an error 403 forbidden bad registration

help please
thank you for your assistance

More than likely when this happens, you have a typo either on the server or on the phone itself. I’d delete the entry in FreePBX and zero the entries on the phone and start over. In 99% of the cases that solves the problem.


i did that multiple times, no luck
i dont know what it is. i had the same config on a trixbox server and was able to register no problem. i wiped trixbox and installed freepbx because it is less restricted. But I am unable to set this up.

Try setting domain to
Check asterisk cli with core set sip set debug on and see what error you get,

Actually switch the outbound to proxy and put IP or DN of FreePBX server in address field and all will be right in the world.

still no luck
when i run asterisk -r
no such command message appears when i try to run sip set debug or sip debug
sip show peers and registry works tho


i really appreciate all the help

Are you using a distro like AsteriskNOW?
What is the output for module show like sip?

Have you rebooted the server?

yes i am using distro asteriskNOW. i have rebooted a few times. I’ll read the extension documentation for asteriskNOW and see if the config is different. I will update when i make the changes from home.


you have done everything right, in the Domain Proxy, select Proxy instead of Domain and give the IP of your PBX server.
It shall work in this way.i am exactly doing this thing these days.

Using your FreePBX, set up an extension
then go to x-lite and configure
in Domain give your PBX IP
Also in Domain Proxy, check Proxy instead of Domain and again puy in the IP og your server,



thanks everyone, i guess it works now, but no matter what call i make i get an operator saying this line is no longer in service. man i can’t seem to do anything right. i’ll keep playing around the with the trunk but i even get that message when i dial *65

nvm i got it all working after i downloaded the modules and deleted and reinstalled the extension on both the pbx and the sip phone

:slight_smile: now to gettin this back up module working