Can't Receive incoming calls

Hello, I had a problem. I have 2 sip trunk from mydivert and then all is registered in FreePBX. I have pointed incoming calls to ext 1000 but I cant receive calls.

I have forwarded RTP 10000- 20000 in my router and 5060 also in my router with freePBX Ip. thanks i need help because it more than a week and i can’t solve it…

No sir. I dont have any license installed.

You did not give enough information to help.

Need FreePBX and Asterisk versions. What type of system (hand built or distro with OS info).

Also need trunk configuration and log output when a call comes in.

Asterisk versions 1.7.1
hand built
Hp Computer
HardDisk 150GB
Processor : Intel Core2 Quad

Trunk Config:
Trunk Name: mydivert

;force keep-alives with qualif=yes


Register String: xxxxxxxxx:[email protected]/xxxxxxxxx

Do you have g.729 CODEC license installed?

Then don’t try and use g729, it won’t work for anything but "pass-through"to a licensed end point.

I use disallow g729 but still not work…

please can you show me step by step how to setup all this code>>>

SIPUSERNAME = Your SIP account username
SIPPASSWORD = Your SIP account password
LOCAL-IP = Your asterisk LOCAL IP address (example:
PUBLIC-IP = Your PUBLIC IP address (example:

The configuration for Asterisk (sip.conf) should look very simlar to this :

context = default
disallow = all
allow = ulaw
allow = alaw
maxexpiry = 120
defaultexpiry = 90
allow = g729 ;a license from digium will be required if transcoding g729 to other codecs, else disallow g729
trustrpid = yes
sendrpid = yes
nat = yes
bindport = 5060
externip = PUBLIC-IP
localnet = LOCAL-IP
useragent = Asterisk

register => SIPUSERNAME:[email protected]/SIPUSERNAME

fromuser = SIPUSERNAME
username = SIPUSERNAME
authuser = SIPUSERNAME
insecure = port,invite
dtmf = rfc2833
disallow = all
allow = g729
allow = ulaw
allow = alaw
type = friend
host =
nat = yes
;force keep-alives with qualify=yes
qualify = yes
;here we state the context for incoming calls on the channel. we need to set this up also in extensions.conf
context = from-mydivert

;this could be your extension - your voip phone using
;insecure = no
;canreinvite = no
;regexten = 8000
;dtmf= rfc2833
;context = sip-phone
;host= dynamic
;type= friend
;username = 8000
;secret = 1234
;nat= yes
;qualify = yes

In extensions.conf you need to setup the context and routing. It would look something like this:




;this is the context we need to setup to receive incoming calls
;first is the default extension that calls arrive on.
exten => SIPUSERNAME,1,Answer
exten => SIPUSERNAME,2,Dial(SIP/8000)
exten => SIPUSERNAME,3,Hangup

;if you have SIP trunking enabled for your account calls will arrive with DID invites.
;You then add each DID in this context with routing. example DID number 15166179421
;exten => 15166179421,1,Answer
;exten => 15166179421,2,Dial(SIP/8000)
;exten => 15166179421,3,Hangup

;this is the context of your extension voip phone dialing into asterisk and placing an outgoing call
;exten => _X.,1,Answer
;if you have caller-id ‘set by equipment’ enabled you can set the CID for the outgoing call via the trunk.
;If not, then the server will set CID for you.
;exten => _X.,2,Set(CALLERID(name)=15166179421)
;exten => _X.,3,Set(CALLERID(num)=15166179421)
;exten => _X.,4,Dial(SIP/${EXTEN}@mydivert,30,Tt)
;exten => _X.,5,Hangup

please remember that I dont have static ip, my ip address change automatically

Ignore extensions.conf freepbx does this for you when you create outbound route.

Use the sip peer settings just as this example in your FreePBX trunk. Change the context to from-trunk and leave off the g.729.

Also read our documentation and review how the trunks and routes are setup.

Wow, that must suck. Start a new thread and provide all the information, phone model + config and method of provisioning etc.

Thank you very much bro, its works now. I changed context to from-trunk and I deleted g729 from the list

some of my sip phone can not call another. if I push any number then I hear busy tone

Well, Phone model: Linksys Firmware Version: 5.1.6(LS)
It have 2 socket for telephone and both are not work. If I hook up, I hear dialing tone but if I call from another phone, then I hear busy tone.

DHCP: Enabled Current IP: 192.168.1.xx
Host Name: LinksysPAP Domain: home
Current Netmask: Current Gateway: 192.168.1.xx
Primary DNS:
Secondary DNS:
Product Information
Product Name: PAP2T Serial Number: FLI00J945603
Software Version: 5.1.6(LS) Hardware Version: 0.3.5
MAC Address: 00259C6BC25A Client Certificate: Installed
Customization: Open
System Status
Current Time: 9/20/2012 20:06:44 Elapsed Time: 00:00:01
Broadcast Pkts Sent: 2 Broadcast Bytes Sent: 684
Broadcast Pkts Recv: 3 Broadcast Bytes Recv: 180
Broadcast Pkts Dropped: 0 Broadcast Bytes Dropped: 0
RTP Packets Sent: 0 RTP Bytes Sent: 0
RTP Packets Recv: 0 RTP Bytes Recv: 0
SIP Messages Sent: 6 SIP Bytes Sent: 3038
SIP Messages Recv: 6 SIP Bytes Recv: 3196
External IP:
Line 1 Status
Display Name: Tel 2 User ID: 2000
Hook State: On Registration State: Online
Last Registration At: 9/20/2012 19:06:42 Next Registration In: 86 s
Message Waiting: No Call Back Active: No
Last Called Number: Last Caller Number:
Mapped SIP Port:

I have to type of that touter and the order one is working fine.