Can't reactivate freepbx

Needed to change my system from a static IP to PPPoE because of changes at my ISP. Made the change to the network config and everything tested out fine. Then went to get into the GUI and wasn’t able to get in… got a message on the console to the effect that I needed to run fwconsole -fix_zend which I did and the process disabled two modules. Was able to then get into the GUI. Went into system admin and the system showed as unactivated so I did a reactivation which was successful. Went into module admin and did a few pending module updates then ended up going back into system admin and the system showed as unactivated. Tried to do a reactivation but this time it’s saying that the deployment id is already licensed to another host and that it needs to be unlinked from the portal. Went into the portal and the only thing that I could find close to unlink was the deactivate button on the deployment which I tried several times. Doesn’t seem to have any affect since I get the same error if I subsequently try to reactivate.

Can anyone tell me what I need to do to get the system re-activated. I wasn’t expecting the whole system to take a dump just by changing the network config.

sangoma guys will have to chime in here. if the portal shows your deployment id licensed to another host you have a problem. if all you did was change the ip address of the system it should not have caused your system to be deactivated. did you by chance use a different NIC with the pppoe connection?

The PPPoE connection is over eth1 just like the static IP was. All I did was create the PPPoE connection, bring it up and verify that I had connectivity and then removed the old static IP info from the NIC. With that said creating a PPPoE connection does result in creation of the ppp0 interface which based on my past experiences with expletive deleted Zend was probably enough to have it throw a fit.

Without a doubt something hiccupped somewhere because the first time it reactivated with no problem and then subsequently decided it was deactivated again.

Same here, my hardware hasn’t changed in 6 months. I just finally got my sip trunk from my telco last week and added the IP for the NIC without a gateway and added a static route to their 10.x.x.x network, restarted the network services, checked the routes and all was fine, rebooted the next day and BLAM my system deactivated again for the 4th time. I am done with the commercial modules until sangoma can provide a hardware dongle for the license managemend, this ZEND software can’t handle multiple NICS at the same time, I have 3 interfaces. if all you have is 1 NIC you are ok.

unless you are using all the nics to access the internet, things should work fine. the key is to either keep the zend id the same by setting the mac address of the nic to the mac address you initially registered from (only doable if you are running a vm) or deregister the pbx and then register it again, but when you register it follow the prompts about already having a deployment id. just grab the deployment id from the sangoma portal and plug it into the system

It’s not always that cut and dried though. In my case the same NIC in the same server connected to the same cable and the same modem. But when you change from a static IP to a PPPoE connection another virtual interface gets created for the PPPoE and poof. As long as the original NIC remains in place that should count for a lot more in whatever their ID process is vs. what new NIC might be getting installed.

I think Zend really needs to take a look at what networking looks like now, as opposed to what it looked like 10 or 15 years ago. NICs are no longer the “stable” pieces of hardware that they used to be to be used as a part of a hardware fingerprint (especially when you start looking at NICs that aren’t physical hardware at all).


Zend no longer makes or upgrades the software that does licensing. Future plans are to migrate off of Zend but for now we are stuck with Zend which is no longer in active development.

Great, can’t wait. the last time my systems deactivated I just gave up using any commercial modules.
I was wanting to install ZULU or the dot net stuff when done but I cant take a chance on my production system.

Keep us informed.