FreePBX | Register | Issues | Wiki | Portal | Support

Can't Move Chan_SIP to port 5160 OR Grandstream HT704 Won't register on 5160


(John Jarrett) #1

I have been using FreePBX Distro14.0.4.5, (12.7.5-1807-1.sng7), using Asterisk 13.22.0 without any issues and it has always just worked as long as it is set up correctly. In this case, I have to be missing something simple.

When I installed this distro I immediately disabled PJSIP, set Chan_SIP (Sip) back to the old port we all know and love, 5060, have a couple old GrandStream phones and an HT704 for a FAX and two analog wireless phones. All works GREAT on good old SIP on port 5060. I have yet to re-add PJSIP (Both) to the mix.

(I am trying to make this short)… In preparing to move over to the new FlowRoute POPS, which use PJSIP, I figured I would move my Sip to 5160, the new default. I have made the necessary port changes to my external firewall and had no troubles registering to FlowRoute’s legacy POPS on port 5160. Set the BIND port under Chan SIP Settings to 5160. Saved and applied. Set the HT704 to use 5160 and rebooted the HT704 AND did an fwconsole restart to ensure all has been applied.

No registration to FreePBX by the HT704. I can dial in and ring any of the phones hooked to the HT704, (not registered?) and talk. Any dial out is just “dead air”… no announcement about the call, i.e., can’t be completed as dialed or… anything.

Forgot to add that I then set the extensions to the HT704 to 5160. Same thing. No registration.

I am on a static Internet IP. All devices on the internal network all also static.

Setting everything back to 5060 and we are back to working like a charm.

What am I missing?

John


(Lorne Gaetz) #2

Bind changes require an Asterisk restart after applying config.


(John Jarrett) #3

Hi Lorne… did it as quoted from my OP.

John


#4

On a Grandstream device, you should specify e.g.
Primary SIP Server: 192.168.123.234:5160
for each FXS port that you are using.
There is no need to change Local SIP Port.

In FreePBX, you shouldn’t have to change anything on a per extension basis. If the device is registering, Asterisk will determine its source port number automatically.
Just change bindport as you noted.


(John Jarrett) #5

@Stewart1, thank-you! I never knew that the port should/could be added to the Primary SIP Server under the GS device config.

It certainly makes some sense and will give it a try in a few days when back at it!

John


(John Jarrett) #6

@Stewart. Managed to do it sooner than I expected. Worked well. But to ensure everything, including SIP registration, happened on 5160 on all my GrandStream devices I had to do your suggestion; `Primary SIP Server: “XXX.XXX.XXX.XXX:5160” and add 5160 to the GrandStream’s Local SIP Port setting.

Sweet success. Knew I was missing something simple and thanks again for pointing me in the right direction!!!

John


(system) #7

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.