Cant modify Baseline for a Yealink Template


I’m not sure if I do not understand how this works or I’m doing something wrong but I’m unable to modify a Baseline. For example, I want to add a Custom Logo to a T42G so I want to change a couple of parameters like lcd_logo.url

I go to Baseline Editor, chose the template and the phone model and click on the parameter I want to change, type what I want on the Value field and click on Change Baseline, then that window closes and nothing, the parameter does not show the change on the value… The extension Mapping screen shows all lines on yellow like it does identify there was a change done but after rebuilding the configs and checking the cfg files generated I can confirm the change did not go through…

I’ve tried with different browsers (Firefox and Chrome) and same result, this is with FreePBX Distro 10.13.66-9 and all modules updated to the latest version.

Any idea what could be wrong?


In case anyone has the same problem, I figure out my mistake:

The Template did not have a Config Style selected, so it was displaying v70 style but when doing changes it was saving in the changes for Legacy style.

Once I went to the template and set the config style to v70, the baseline editing worked just as expected.