Cant make calls, then MISDN advice please

why won’t my snom 360 work??? I have re-writen this post see below please.

I wanted to get MISDN working on the freepbx Distro. I searched the forum and from reading posts I got the impression that some of the required files are not included in the stable distro, but are in the Beta version.

I downloaded the Beta version set it up and upgraded to, the latest update I have found.

I registered 2 phones to the system an optipoint and a Snom. for some reason and I can’t see why, I can’t make internal calls from the snom phone. the display comes up with Not acceptable here and if I look at the sip log on the phone GUI I see 401 Unauthorized. I tried updating the snom firmware but, no different.

I have also have a trixbox on my network so I set up an extension with the same cridentials on the trixbox. If I go to the snom GUI and change the registrar IP address then I can register it to trixbox and it works fine.

Can some one please help me find out why it won’t work on the freepbx, It worked on the stable release. But I cant get it to make calls on the Beta version.

there doesnt seem much point in trying to get MISDN going if I cant get the phone to work…

Help please…

Yes, you are missing something!

Asterisk 1.8 supports TLS encryption. The SNOM phones have TLS turned on by default. Since you don’t have certificates the TLS won’t work.

Go into the RTP menu on the SNOM and turn off TLS.