Can't log on to Web GUI

I’ve been fixing errors and bugs as I’ve found them on my system (Arch Linux for an ARM system). I’ve successfully installed Asterisk and FreePBX (I think). When I login using my IP I just get a blank screen except for a directory listing for freepbx but when I click on it, it gives me a directory listing for “parent directory”.
IP/admin doesn’t work or IP/maint or even localhost

After running ./install_amp, I’m not really seeing major errors, I’m copy and pasting the output here for any kind soul that could help me:

[[email protected] freepbx]# ./install_amp
Checking for PEAR DB..OK
Checking for PEAR Console::Getopt..OK
Checking user..OK
Checking if Asterisk is running..running with PID: 2529..OK
Checking for /etc/amportal.conf..OK
Reading /etc/amportal.conf..parsed amp_conf variables from /etc/amportal.conf:
amp_conf [ASTMANAGERHOST] => [localhost]
amp_conf [AMPMGRPASS] => [amp111]
amp_conf [ASTMANAGERPORT] => [5038]
amp_conf [ASTMANAGERPROXYPORT] => []
amp_conf [AMPMGRUSER] => [admin]
amp_conf [ASTMGRWRITETIMEOUT] => [5000]
amp_conf [AMPLOCALBIN] => []
amp_conf [FPBXDBUGFILE] => [/var/log/asterisk/freepbx_debug]
amp_conf [DEVEL] => [TRUE]
amp_conf [FPBXDBUGDISABLE] => [TRUE]
amp_conf [DEVELRELOAD] => [TRUE]
amp_conf [CFRINGTIMERDEFAULT] => [0]
amp_conf [ASTCONFAPP] => [app_confbridge]
amp_conf [ZAP2DAHDICOMPAT] => [TRUE]
amp_conf [ENABLECW] => [TRUE]
amp_conf [DISABLECUSTOMCONTEXTS] => [TRUE]
amp_conf [DYNAMICHINTS] => [TRUE]
amp_conf [USEDEVSTATE] => [TRUE]
amp_conf [CONCURRENCYLIMITDEFAULT] => [0]
amp_conf [FCBEEPONLY] => [TRUE]
amp_conf [DIVERSIONHEADER] => [TRUE]
amp_conf [NOOPTRACE] => [0]
amp_conf [CWINUSEBUSY] => [TRUE]
amp_conf [ASTSTOPPOLLINT] => [2]
amp_conf [AMPBADNUMBER] => [TRUE]
amp_conf [USEGOOGLEDNSFORENUM] => [TRUE]
amp_conf [ASTSTOPTIMEOUT] => [120]
amp_conf [ASTAGIDIR] => [/var/lib/asterisk/agi-bin]
amp_conf [ASTVARLIBDIR] => [/var/lib/asterisk]
amp_conf [ASTETCDIR] => [/etc/asterisk]
amp_conf [ASTLOGDIR] => [/var/log/asterisk]
amp_conf [ASTMODDIR] => [/usr/lib/asterisk/modules]
amp_conf [ASTRUNDIR] => [/run/asterisk]
amp_conf [ASTSPOOLDIR] => [/var/spool/asterisk]
amp_conf [AMPCGIBIN] => [/var/www/cgi-bin\\\\\\ ]
amp_conf [AMPBIN] => [/var/lib/asterisk/bin]
amp_conf [AMPSBIN] => [/usr/local/sbin]
amp_conf [AMPWEBROOT] => [/var/www/html]
amp_conf [MOHDIR] => [moh]
amp_conf [FOPWEBROOT] => [/var/www/html/panel]
amp_conf [BADDESTABORT] => [TRUE]
amp_conf [XTNCONFLICTABORT] => [TRUE]
amp_conf [CHECKREFERER] => [TRUE]
amp_conf [SERVERINTITLE] => [TRUE]
amp_conf [CUSTOMASERROR] => [TRUE]
amp_conf [RELOADCONFIRM] => [TRUE]
amp_conf [SHOWLANGUAGE] => [TRUE]
amp_conf [MODULEADMINWGET] => [TRUE]
amp_conf [CDRDBHOST] => []
amp_conf [CDRDBNAME] => []
amp_conf [CDRDBPASS] => []
amp_conf [CDRDBPORT] => []
amp_conf [CDRDBTABLENAME] => []
amp_conf [CDRDBTYPE] => []
amp_conf [CDRDBUSER] => []
amp_conf [AMPSYSLOGLEVEL] => [FILE]
amp_conf [AMPDISABLELOG] => [TRUE]
amp_conf [AMPEXTENSIONS] => [extensions]
amp_conf [AUTHTYPE] => [database]
amp_conf [AMPVMUMASK] => [007]
amp_conf [AMPWEBADDRESS] => [192.168.1.9]
amp_conf [AMPASTERISKGROUP] => [asterisk]
amp_conf [AMPASTERISKUSER] => [asterisk]
amp_conf [AMPDEVGROUP] => [asterisk]
amp_conf [AMPDEVUSER] => [asterisk]
amp_conf [AMPASTERISKWEBGROUP] => [asterisk]
amp_conf [AMPASTERISKWEBUSER] => [asterisk]
amp_conf [AMPENGINE] => [asterisk]
amp_conf [AMPDBUSER] => [asteriskuser]
amp_conf [AMPDBPASS] => [amp109]
amp_conf [AMPDBHOST] => [localhost]
amp_conf [AMPDBNAME] => [asterisk]
amp_conf [AMPDBENGINE] => [mysql]
amp_conf [datasource] => []
amp_conf [AMPENABLEDEVELDEBUG] => []
amp_conf [TCINTERVAL] => [60]
amp_conf [TCMAINT] => [1]
amp_conf [DAYNIGHTTCHOOK] => []
OK
Checking for /etc/asterisk/asterisk.conf..OK
Reading /etc/asterisk/asterisk.conf..OK
Using asterisk as PBX Engine
Checking for Asterisk version..11.11.0
Checking for selinux..OK
Connecting to database..OK
Checking current version of AMP..2.11.0
Installing new FreePBX files../etc/asterisk/cdr_mysql.conf has been changed from the original version.
Overwrite (y=yes/a=all/n=no/d=diff/s=shell/x=exit)? a
OK (227 files copied, 0 skipped)
amportal..no fpbx..freepbx_engine..freepbx_setting..gen_amp_conf.php..done
apply username/password changes to conf files:
running apply_conf.sh from freepbx_settings
Bootstrapping Configuration Settings
Updating configuration...
/etc/asterisk/cdr_mysql.conf user: [asteriskuser] password: [amp109] hostname: [localhost]
/etc/asterisk/manager.conf user: [admin] secret: [amp111]
Adjusting File Permissions..

Please wait...

SETTING FILE PERMISSIONS
Permissions OK
Done
done with apply_conf.sh
creating missing #include files..OK
OK
Setting permissions on files..OK
Checking for upgrades..No further upgrades necessary
Creating or updating freepbx_conf settings....OK
Setting freepbx settings form /etc/amportal.conf
freepbx setting [ASTMANAGERHOST] set to [localhost]
PHP Notice:  Undefined variable: ret3 in /usr/src/freepbx/amp_conf/htdocs/admin/libraries/utility.functions.php on line 1389
freepbx setting [AMPMGRPASS] set to [amp111]
freepbx setting [ASTMANAGERPORT] set to [5038]
freepbx setting [ASTMANAGERPROXYPORT] set to []
PHP Notice:  Undefined variable: ret3 in /usr/src/freepbx/amp_conf/htdocs/admin/libraries/utility.functions.php on line 1389
freepbx setting [AMPMGRUSER] set to [admin]
freepbx setting [ASTMGRWRITETIMEOUT] set to [5000]
freepbx setting [AMPLOCALBIN] set to []
freepbx setting [FPBXDBUGFILE] set to [/var/log/asterisk/freepbx_debug]
freepbx setting [DEVEL] set to [TRUE]
freepbx setting [FPBXDBUGDISABLE] set to [TRUE]
freepbx setting [DEVELRELOAD] set to [TRUE]
freepbx setting [CFRINGTIMERDEFAULT] set to [0]
freepbx setting [ASTCONFAPP] set to [app_confbridge]
freepbx setting [ZAP2DAHDICOMPAT] set to [TRUE]
freepbx setting [ENABLECW] set to [TRUE]
freepbx setting [DISABLECUSTOMCONTEXTS] set to [TRUE]
freepbx setting [DYNAMICHINTS] set to [TRUE]
freepbx setting [USEDEVSTATE] set to [TRUE]
freepbx setting [CONCURRENCYLIMITDEFAULT] set to [0]
freepbx setting [FCBEEPONLY] set to [TRUE]
freepbx setting [DIVERSIONHEADER] set to [TRUE]
freepbx setting [NOOPTRACE] set to [0]
freepbx setting [CWINUSEBUSY] set to [TRUE]
freepbx setting [ASTSTOPPOLLINT] set to [2]
freepbx setting [AMPBADNUMBER] set to [TRUE]
freepbx setting [USEGOOGLEDNSFORENUM] set to [TRUE]
freepbx setting [ASTSTOPTIMEOUT] set to [120]
freepbx setting [ASTAGIDIR] set to [/var/lib/asterisk/agi-bin]
freepbx setting [ASTVARLIBDIR] set to [/var/lib/asterisk]
freepbx setting [ASTETCDIR] set to [/etc/asterisk]
freepbx setting [ASTLOGDIR] set to [/var/log/asterisk]
freepbx setting [ASTMODDIR] set to [/usr/lib/asterisk/modules]
freepbx setting [ASTRUNDIR] set to [/run/asterisk]
freepbx setting [ASTSPOOLDIR] set to [/var/spool/asterisk]
freepbx setting [AMPCGIBIN] set to [/var/www/cgi-bin\\\\\\ ]
freepbx setting [AMPBIN] set to [/var/lib/asterisk/bin]
freepbx setting [AMPSBIN] set to [/usr/local/sbin]
freepbx setting [AMPWEBROOT] set to [/var/www/html]
freepbx setting [MOHDIR] set to [moh]
freepbx setting [FOPWEBROOT] set to [/var/www/html/panel]
freepbx setting [BADDESTABORT] set to [TRUE]
freepbx setting [XTNCONFLICTABORT] set to [TRUE]
freepbx setting [CHECKREFERER] set to [TRUE]
freepbx setting [SERVERINTITLE] set to [TRUE]
freepbx setting [CUSTOMASERROR] set to [TRUE]
freepbx setting [RELOADCONFIRM] set to [TRUE]
freepbx setting [SHOWLANGUAGE] set to [TRUE]
freepbx setting [MODULEADMINWGET] set to [TRUE]
freepbx setting [CDRDBHOST] set to []
freepbx setting [CDRDBNAME] set to []
freepbx setting [CDRDBPASS] set to []
freepbx setting [CDRDBPORT] set to []
freepbx setting [CDRDBTABLENAME] set to []
freepbx setting [CDRDBTYPE] set to []
freepbx setting [CDRDBUSER] set to []
freepbx setting [AMPSYSLOGLEVEL] set to [FILE]
freepbx setting [AMPDISABLELOG] set to [TRUE]
freepbx setting [AMPEXTENSIONS] set to [extensions]
freepbx setting [AUTHTYPE] set to [database]
freepbx setting [AMPVMUMASK] set to [007]
freepbx setting [AMPWEBADDRESS] set to [192.168.1.9]
freepbx setting [AMPASTERISKGROUP] set to [asterisk]
freepbx setting [AMPASTERISKUSER] set to [asterisk]
freepbx setting [AMPDEVGROUP] set to [asterisk]
freepbx setting [AMPDEVUSER] set to [asterisk]
freepbx setting [AMPASTERISKWEBGROUP] set to [asterisk]
freepbx setting [AMPASTERISKWEBUSER] set to [asterisk]
freepbx setting [AMPENGINE] set to [asterisk]
freepbx setting [AMPDBUSER] DOES NOT EXIST, can't set to [asteriskuser]
freepbx setting [AMPDBPASS] DOES NOT EXIST, can't set to [amp109]
freepbx setting [AMPDBHOST] DOES NOT EXIST, can't set to [localhost]
freepbx setting [AMPDBNAME] DOES NOT EXIST, can't set to [asterisk]
freepbx setting [AMPDBENGINE] DOES NOT EXIST, can't set to [mysql]
freepbx setting [datasource] DOES NOT EXIST, can't set to []
freepbx setting [AMPENABLEDEVELDEBUG] DOES NOT EXIST, can't set to []
freepbx setting [TCINTERVAL] DOES NOT EXIST, can't set to [60]
freepbx setting [TCMAINT] DOES NOT EXIST, can't set to [1]
freepbx setting [DAYNIGHTTCHOOK] DOES NOT EXIST, can't set to []
Generating AMP configs..
Generating Configurations.conf, (if Asterisk is not running, you will get an error
In case of error, start Asterisk and hit the red bar in the GUI to generate the Configurations.conf files
Checking for PEAR Console::Getopt..OK
Running module install.php and install.sql scripts
Skipping extension and destination registry checks
sh: /usr/bin/crontab: No such file or directory
sh: /usr/bin/crontab: No such file or directory
sh: /usr/bin/crontab: No such file or directory
/bin/echo: write error: Broken pipe
Please update your modules and reload Asterisk by visiting http://192.168.1.9/admin
Generating AMP configs..OK
Please update your modules and reload Asterisk by visiting http://192.168.1.9/admin

*************************************************************************
* Note: It's possible that if you click the red 'Update Now' bar BEFORE *
* updating your modules, your machine will start dropping calls. Ensure *
* that all modules are up to date BEFORE YOU CLICK THE RED BAR. As long *
* as this is observed, your machine will be fully functional whilst the *
* upgrade is in progress.                                               *

Three things I suggest you do before ANYTHING ELSE!!

1 visit http://www.freepbx.org/download-freepbx and make sure you have all the prerequisites available

2 run ./install_amp --help and read what options are available as parameters

3 read ./install_amp and understand what any variables will do in your particular environment.

If any thing is unclear, start at step one again . . . .

I would also have to ask “Why ArchLinux?” , it is perhaps the most demanding Linux to install and requires a very deep and complete understanding of how linux works. Not that I am discouraging your efforts, far from it, if you succeed then I bet you will have a better understanding of all things Asterisk/FreePBX than most here, but I am pretty sure there are only a very small handful of people here who have ever even tried it, so support will be pretty well non-existant, so if you have an ARM, why not start with RaspPBX where it is mostly all done for you already? Yes It is Debian not ArchLinux but at least you can boot strap your efforts with a solid knowledge base . . .

1 Like

I’m using Arch Linux because it’s one of the few distros that works well with my ARM v7 system. In this case a quad core UDOO ARM cpu computer. The other choice would have been a specific distro called Udoo Ubuntu. The developers aren’t keeping up with the Kernel though so installing FreePbx there was almost impossible for me. Others have successfully installed FreePBX on Arch even on ARCH ARM.

I’ll run ./install_amp --help tomorrow and see what I can come up with.

What stumps me is that I didn’t see any major errors during initialization of FreePBX. The GUI won’t load though and I just get a directory structure on my browser.

I hate to say it, but what will really stump you is that unless you are a total linux savant, it will be ArchLInux itself, it is NOT for newbies. For a start you will probably need to recompile the kernel itself with 1000HZ kernel timing to avail yourself of res_timing_timerfd.so, that will be just the start of your adventures.

Other than that, install_amp is the self-referential script that you will need to resort to for anything that doesn’t work, sorry, but you are likely on your own from here on in. (there was a guy here a couple of weeks ago (use the search box) who got similarly stumped by Arch, maybe you guys should pool resources)

(I looked, I see no reason why RasPBX would not install on your hardware, it is after all just a big fat raspberry, did you even consider it?)

Thanks for the candor.
Well, for my udoo, CentOS isn’t really an option. They announced that they’re working on an ARM version but nothing yet.
There does seem to be a way of getting Fedora on an ARM based system.
I guess if I can’t get things working on my UDOO system we’ll just go with a cloud based install instead. This has taken up too much of my energy and time as it is…