Can't link outbound route to specific extension

Hi, I use Yeastar TG200 LTE with my FreePBX system. I inserted two SIM cards into the gate. My goal is to have each of them linked to two different extensions.
Let’s say:
SIM1/Trunk 1 ↔ 2000 (extension)
SIM2/Trunk 2 ↔ 2001 (extension)

I followed this guide to install first extension with routes from here:

…and did the same steps from 2.2 to the end to create the second one.

Inbound routes works exactly as I want to. When I call SIM1 it goes to 2000 extension, and when I call SIM2 it goes to 2001.

Unfortunently, when doing outbound call, both extensions use SIM1. 2001 extension does not use SIM2 as I intended.

I tried to set-up callerID in FreePBX outbound route for each extension in dial plan, but it doesn’t seem to work (attachment_1.png)

solution from: Linking specific Extension to specific OutBound Routes - #3 by Stewart1

What else I can do to link sim cards to specific extension? FreePBX version:

With the help of Yeastar support I’ve managed to make it work. Here is the solution:

  1. login to yeastar gateway via website
  2. go to IP to mobile settings
  3. input your extension number into: Inbound caller pattern for each of the routes.
  4. callerID in dial patterns in FreePBX are not necessary.

You can close this topic as it’s solved.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.