Can't intstall FreePBX13 due to pgp error


#1

Trying to install a new FreePBX13 Distro so I can restore an older system, then upgrade it to 14.

Problem is, getting the PGP error because the keys are out of date and apparently the only fix is to install from the edge repository…

Problem is, I have no advanced settings available in the gui because core and framework aren’t installed properly so I can’t turn on edge.

Is there a way to turn it on via the command line? I tried fwconsole ma --edge but that fails.

fwconsole ma --edge install core

[RuntimeException]
The “–edge” option does not exist.

Suggestions?


(Dave Burgess) #2

I think the option placement might be important there.

Also, downloadinstall will pull the right files down as well as install them. The install option will only install them once they’re downloaded.


#3

thanks for the suggestion but NG… :frowning:

[root@207 ~]# fwconsole ma downloadinstall framework --edge && fwconsole ma downloadinstall core --edge && fwconsole r

[RuntimeException]
The “–edge” option does not exist.


(Dave Burgess) #4

Time for more info:

Version numbers would be a good start. Edge support has been around for several years, so it would seem very odd that you could do a new install and not have it supported.


#5

this is a distro13 install from the legacy iso… brand new, first boot just getting it set up to install the backup from an older system.


(Dave Burgess) #6

Respectfully, I recommend against this course of action.

FreePBX 15 now supports restores from (almost) all previous versions. If you are installing a new system, I’d highly recommend starting with a new distro and doing the restore once you get it working. I understand that you’ve got a plan right now, but ultimately, you are going to end up at FreePBX 15 (after you get done with the online upgrades) so starting them would simply save you a lot of headaches in the intervening steps.


#7

i was unaware that 15 allowed restore from older version backups. If that’s the case then that’s what I’ll try


(Dave Burgess) #8

That’s why we’re here - to help out.


(Chris Dolese) #9

i believe this may have resolved the pgp error …

su - asterisk -c “gpg --refresh-keys --keyserver pgp.mit.edu

you’re better off restoring to 15 though


#10

tried that before I posted… no dice

spinning up v15 now. we’ll see how it goes


(Lorne Gaetz) #11

Prior to the restore in 15, I recommend you upgrade all modules to current (obviously) but also upgrade the backup module to edge with:

fwconsole ma upgrade backup --edge

Backup module is getting bug fixes pretty much weekly at this point.


#12

oooof … too late. already running the restore. if it fails I’ll load the edge module.


#13

Thanks Lorne


#14

backup failed but I’m thinking its because the PHP script load time limit of 30 seconds was exceeded.

just upgraded backup to the current edge version. time to try again.


(Lorne Gaetz) #15

Use the command line:

fwconsole backup --restore [/path/to/restore-xxxxxx.tar.gz]

#16

:+1::+1::+1:


#17

Worked like a champ Lorne!! Thanks again!


(system) closed #18

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.