Can't install Stable-1.812.210.57 on a HP/Compaq DC5800

Hello! I have dozens of customers currently running Trixbox. Since it’s no longer actively developed, I’ve been testing various distros to try and find an alternative that’s suitable for use in small businesses (less than 25 simultaneous calls). I’ve narrowed it down to Elastix, PBX in a Flash, and the FreePBX distro. I’ve installed the other 2 without issue and tested those. For the life of me, I can’t get the FreePBX distro loaded. The CD boots, and I enter all the pertinent information (ip addresses, passwords, etc.) The installer starts to format the drive, and that’s when things appear to go south. Immediately following the format process, I get an error that says that the Install image can’t be transferred to the hard drive because it may be full, and the install process stops.

The PC is a 3 Ghz Core 2 Duo, 2GB RAM, gigabit network adapter, and 160GB hard drive. Pretty vanilla stuff.

Anyone have any ideas?


Sounds like you are not telling it to reformat the hard drives. Like they are partioned for linux already and it is trying to use those partions.

It didn’t ask me if I wanted to format the drive. It just started formatting. I thought that having the linux partition from the other test might be an issue, so I disconnected the drive, put it in a USB to SATA adapter, and removed the partitions altogether so that the drive was totally blank.

Same thing happened when I tried it again. I’ve just installed a brand new 1TB drive. It’s taking forever to format. I’ll update this thread when it’s done. Thanks for the quick response!

Ok, so I’ve had to stop this installation again. I’ve been waiting for an hour, and the format process is at 15%. Is there no way to quick format using this distro? Every other linux install that I have done (literally hundreds) take less than 30 minutes to install. Any way to speed this up?

Are you using the netinstall or full iso? I do 2Tb drive installs all the time. Sounds like centos 5.7 does not like your hardware.

I would do Full Install and pick the advanced option. The auto raid usually does not work well with high end hardware which I think is your issue.

I’m using the full ISO. I’ve tried all 3 methods of installation - auto raid, no raid and advanced. No joy. I’d try different hardware, but this is the same platform that I use for all my clients. I’ll start the install again, and see what happens. Thanks!

Well if you use advanced mode that is just stock Centos 5.7 install system.

You could also try version 1.812.210.58 which is the same that you are doing now except it uses Centos 5.8 instead of 5.7

Downloading it now. Thanks for the heads up.