Can't install PHP-XML after upgrade to FPBX 12

I upgraded to FreePBX 12.0.1rc17 and when I go to Reporting - Status the FreePBX Statistics box says
:
PHP-XML is a requirement of PHP SysInfo. System Statistics are disabled until that package is installed.
This can be resolved by installing the ‘php-xml’ package on most distributions, and then restarting Apache

If I try to upgrade or install PHP-XML in the OS I get:
–> Finished Dependency Resolution
php-5.3.28-3.shmz510.4.11.i386 from schmooze-commercial has depsolving problems
–> Missing Dependency: t1lib is needed by package php-5.3.28-3.shmz510.4.11.i386 (schmooze-commercial)
php-cli-5.3.28-3.shmz510.4.11.i386 from schmooze-commercial has depsolving problems
–> Missing Dependency: libedit.so.0 is needed by package php-cli-5.3.28-3.shmz510.4.11.i386 (schmooze-commercial)
php-gd-5.3.28-3.shmz510.4.11.i386 from schmooze-commercial has depsolving problems
–> Missing Dependency: libt1.so.5 is needed by package php-gd-5.3.28-3.shmz510.4.11.i386 (schmooze-commercial)
php-5.3.28-3.shmz510.4.11.i386 from schmooze-commercial has depsolving problems
–> Missing Dependency: libedit is needed by package php-5.3.28-3.shmz510.4.11.i386 (schmooze-commercial)
Error: Missing Dependency: t1lib is needed by package php-5.3.28-3.shmz510.4.11.i386 (schmooze-commercial)
Error: Missing Dependency: libt1.so.5 is needed by package php-gd-5.3.28-3.shmz510.4.11.i386 (schmooze-commercial)
Error: Missing Dependency: libedit is needed by package php-5.3.28-3.shmz510.4.11.i386 (schmooze-commercial)
Error: Missing Dependency: libedit.so.0 is needed by package php-cli-5.3.28-3.shmz510.4.11.i386 (schmooze-commercial)

You are on a FreePBX distro machine. You should really consider upgrading the distro through the normal steps.

http://wiki.freepbx.org/display/FD/Updating+FreePBX+Official+Distro

This system is at 1.812.210.57-1 the unsupported tracks start at Centos 5.7
Do I have any options?

I downloaded the upgrade-1.812.210.57-1.sh script but it failed to run:

cat: /etc/asterisk/freepbxdistro-version: No such file or directory
Check to make sure this is a FreePBX Distro system before executing
This does not appears to be a FreePBX Distro system as it has no FreePBX Distro Version file

The 1.XXX.21-.57 releases have not been supported in 3 plus years. They are locked forever on CentOS 5.X as their is no upgrade path to CentOS 6.X from 5.X. You will need to reinstall with a updated ISO.

OK, thanks.

On 2014-09-15 08:01, tonyclewis wrote:

tonyclewis
[1]
September 15

The 1.XXX.21-.57 releases have not been
supported in 3 plus years. They are locked forever on CentOS 5.X as
their is no upgrade path to CentOS 6.X from 5.X. You will need to
reinstall with a updated ISO.

To respond, reply to this email or
visit
Can't install PHP-XML after upgrade to FPBX 12
[2] in your browser.

PREVIOUS
REPLIES

jkonc [3]
September 14

I downloaded the
upgrade-1.812.210.57-1.sh script but it failed to run:

cat:
/etc/asterisk/freepbxdistro-version: No such file or directory
Check
to make sure this is a FreePBX Distro system before executing
This
does not appears to be a FreePBX Distro system as it has no FreePBX
Distro Version file

jkonc [3]
September 14

This system is
at 1.812.210.57-1 the unsupported tracks start at Centos 5.7
Do I
have any options?

tm1000 [4]
September 14

You are on a
FreePBX distro machine. You should really consider upgrading the distro
through the normal steps.

http://wiki.freepbx.org/display/FD/Updating+FreePBX+Official+Distro [5]

jkonc [3]
September 14

I upgraded to FreePBX 12.0.1rc17
and when I go to Reporting - Status the FreePBX Statistics box says

:

PHP-XML is a requirement of PHP SysInfo. System Statistics are
disabled until that package is installed.
This can be resolved by
installing the ‘php-xml’ package on most distributions, and then
restarting Apache

If I try to upgrade or install PHP-XML in the OS
I get:
–> Finished Dependency Resolution

php-5.3.28-3.shmz510.4.11.i386 from schmooze-commercial has depsolving
problems

–> Missing Dependency: t1lib is needed by package
php-5.3.28-3.shmz510.4.11.i386 (schmooze-commercial)

php-cli-5.3.28-3.shmz510.4.11.i386 from schmooze-commercial has
depsolving problems

–> Missing Dependency: libedit.so.0 is needed by
package php-cli-5.3.28-3.shmz510.4.11.i386 (schmooze-commercial)

php-gd-5.3.28-3.shmz510.4.11.i386 from schmooze-commercial has
depsolving problems

–> Missing Dependency: libt1.so.5 is needed by
package php-gd-5.3.28-3.shmz510.4.11.i386 (schmooze-commercial)

php-5.3.28-3.shmz510.4.11.i386 from schmooze-commercial has depsolving
problems

–> Missing Dependency: libedit is needed by package
php-5.3.28-3.shmz510.4.11.i386 (schmooze-commercial)
Error: Missing
Dependency: t1lib is needed by package php-5.3.28-3.shmz510.4.11.i386
(schmooze-commercial)
Error: Missing Dependency: libt1.so.5 is needed
by package php-gd-5.3.28-3.shmz510.4.11.i386 (schmooze-commercial)

Error: Missing Dependency: libedit is needed by package
php-5.3.28-3.shmz510.4.11.i386 (schmooze-commercial)

Error: Missing
Dependency: libedit.so.0 is needed by package
php-cli-5.3.28-3.shmz510.4.11.i386 (schmooze-commercial)