Can't get Webmin to work

I’m tring to get Webmin to work.
I have run the rpm -hiv webmin… And the install went fine.

But when I try to access webmin: https:freepbx_ip:10000
I get: Error 107 (net::ERR_SSL_PROTOCOL_ERROR): SSL protocol error.

PUTTY and Winscp work find.
I have also stopped the firewall: /etc/init.d/iptables stop

Any ideas?

TIA, Ira

Try

http://IP_ADDRESS:10000/

or

https://IP_ADDRESS:10000

Actually that was the URL I tried: https://IP_ADDRESS:10000
I tried on IE8 and Chrome.

Still looking to get Webmin working.

Does anybody have any ideas?

Ira

Is webmin running? You aren’t going to get much support for webmin around here. I assume there are 100’s of pages on how to troubleshoot webmin. It has it’s own services such as an http server so you need to make sure they are started and running.

It appears to be running looking at ps aux:
root 3731 0.0 0.6 15368 13128 ? Ss Nov04 0:00 /usr/bin/perl /usr/libexec/webmin/miniserv.pl /etc/webmin/miniserv.conf

I did a query on the 107 error and got nothing that helped.

Didn’t know if anyone else here had had the same issue.

How did you install Webmin? If you’re using PBX In A Flash, they changed the default port on Webmin to avoid conflicts with Asterisk which also uses 10,000.

If you are using PIAF, check their web-site. I can’t remember off-hand which port they changed it to.

If you installed Webmin yourself, then I can’t offer further assistance. I’ve never used.

This worked for me:

cd /usr/src
wget http://prdownloads.sourceforge.net/webadmin/webmin-1.570-1.noarch.rpm
rpm -i webmin-1.570-1.noarch.rpm

With that https://ipaddress:10000 should get you into Webmin.

Assuming a PiaF install they use something other then port 10000.

Thanks for all the responses.

I was able to access Webmin by not using the HTTP"S".
Somehow I downloaded a version that does not use https://

Thanks again for all the help.

Ira